Bug 3940 - valid users = @group does not work as 3.0.22!
valid users = @group does not work as 3.0.22!
Status: RESOLVED DUPLICATE of bug 3949
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
Other Windows XP
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2006-07-17 09:38 UTC by Bartlomiej Solarz-Niesluchowski
Modified: 2006-07-20 13:14 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Bartlomiej Solarz-Niesluchowski 2006-07-17 09:38:59 UTC
Issue begins with 3.0.23 -> 3.0.22 works correctly!

When I have SMB server 3.0.23 (domain_member) joined to domain (domain is on samba 3.0.23 too), and I not use winbind and i have unix group named group and in share i have valid users = @group it does not allow me to connect to share.

When i use istead of @unix_group -> @WINDOWS.DOMAIN\windows_group it works

relevant extract from log file (user = solarz group = users - user solarz is in unix group users):
[2006/07/17 15:49:16, 3] lib/util_sid.c:string_to_sid(223)
  string_to_sid: Sid @users does not start with 'S-'.
[2006/07/17 15:49:16, 5] smbd/password.c:user_in_netgroup(423)
  Unable to get default yp domain
[2006/07/17 15:49:16, 10] smbd/share_access.c:user_ok_token(208)
  User solarz not in 'valid users'
[2006/07/17 15:49:16, 2] smbd/service.c:make_connection_snum(571)
  user 'solarz' (from session setup) not permitted to access this share (private)

Here are similar problems:
Comment 1 Gerald (Jerry) Carter 2006-07-20 13:14:47 UTC

*** This bug has been marked as a duplicate of 3949 ***