Bug 3934 - cifs mounts return a zero byte file
cifs mounts return a zero byte file
Product: CifsVFS
Classification: Unclassified
Component: kernel fs
x86 Linux
: P3 normal
: ---
Assigned To: Steve French
Depends on:
  Show dependency treegraph
Reported: 2006-07-14 10:18 UTC by Kendall Cobb
Modified: 2009-05-13 15:58 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Kendall Cobb 2006-07-14 10:18:07 UTC
This is a fresh installation of Fedora Core 5. I have 3 XP
machines that I mount by CIFS in my fstab. CIFS mounts the shares with
no problem. I can view and read files on the shares. The problem I have
is when I try to copy a file from any of the XP machines back to the
Linux box. The file will contain zero bytes. If I ftp into the box and
navigate to the mounts & try to ftp a file, the error is "426 Failure
writing network stream." This happens with any ftp client that I have
tried. There are no firewalls on Linux box or the XP machines. I have
uninstalled SAMBA & then reinstalled SAMBA but that did not help. Here
is a copy of the syntax that I'm using in my fstab.

//hal9000/movies /mnt/Movies cifs
password=nfsnobody,username=nfsnobody 0 0

On the XP machine HAL9000, there is a local user names nfsnobody with a
password nfsnobody. Nfsnobody has full control on the share movies. I
also went to the directory security and add nfsnobody with full control.
Nobody seems to have an answer for this one as I'm clueless as well.

Thank you
Comment 1 Shirish S. Pargaonkar 2006-12-09 08:49:53 UTC
How big is the file that contains zero bytes when it is copied back from XP
mounted shares on FC5 linux box on that FC5 linux box?
Does a large file and a small file, both have same problem?
Are sizes of the source and destination files same but a command like 
md5sum gives different output?

Regarding downloading the file from FC5 linux box to a an ftp client box 
using ftp, there is similar bug 3833 being worked on.
Comment 2 Shirish S. Pargaonkar 2009-03-20 00:37:16 UTC
Is this still an issue?
Comment 3 Steve French 2009-05-13 15:58:22 UTC
No response for a while - no additional reports of this, probably long fixed