Bug 3908 - Can't change user password in XP / 3.0.23RC3
Summary: Can't change user password in XP / 3.0.23RC3
Status: CLOSED FIXED
Alias: None
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts (show other bugs)
Version: 3.0.23
Hardware: Other Windows XP
: P3 critical
Target Milestone: none
Assignee: Gerald (Jerry) Carter
QA Contact: Samba QA Contact
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-03 03:06 UTC by Daniel Beschorner
Modified: 2006-07-06 07:05 UTC (History)
0 users

See Also:


Attachments
ensure that the pipe authentication can access the user's password (431 bytes, patch)
2006-07-03 09:29 UTC, Gerald (Jerry) Carter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Beschorner 2006-07-03 03:06:36 UTC
"System can't change your password, because domain ... isn't available" after I entered the passwords and pushed OK.
Comment 1 Gerald (Jerry) Carter 2006-07-03 06:35:51 UTC
Reproduced.  Thanks for the report.  I'll look into it.
Comment 2 Gerald (Jerry) Carter 2006-07-03 09:29:51 UTC
Created attachment 2015 [details]
ensure that the pipe authentication can access the user's password
Comment 3 Gerald (Jerry) Carter 2006-07-03 09:30:42 UTC
This should fix the NTLMSSP pipe verifier by ensuring that 
the authentication is done as root (else smbd cannot retreive 
the user's password)
Comment 4 Daniel Beschorner 2006-07-06 07:05:05 UTC
works.