Bug 3854 - Cannot access files with a question mark in their names with "mangled names=no"
Cannot access files with a question mark in their names with "mangled names=no"
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.22
Other Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
http://bugs.debian.org/374967
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-24 05:54 UTC by Christian Perrier
Modified: 2006-06-24 13:34 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Perrier 2006-06-24 05:54:43 UTC
From the Debian Bug Tracking System:

       This may be related to the previously reported quotation mark
bug (Debian bug #333778), but I'm not sure.

        Anyway, I have a file named:
---
02-you know what you are?.flac

which appears as:

0J1HP7~2

with the default "mangle names = yes".  I can copy it to the local
machine, so with the default settings, the file is in fact accessible
(although Winamp doesn't like it much admittedly).

        With "mangle names = no", the file name shows up correctly, but
the file cannot be copied to the local machine giving an error of:
---
Cannot copy 02-you know what you are?: The filename, directory name, or
volume label syntax is incorrect.

under Windows XP Professional.

        So really, it's basically exactly the same bug as the quotation
bug.  But the problem is, by disabling name mangling, the file becomes
inaccessible, or at least does in this situation for me.  I've got a
number of other files with question marks in the their names which
exhibit the same problem.  It looks like upstream really should look
into this probably and I'd be interested if the people experiencing the
quotation mark bug were able to access the unmangled name version of the
ile or not.  Strangely, I can right click on the file and view its
properties from Windows, but any attempt to copy it results in the
aforementioned message and a rename attempt gave me:
---
Cannot rename file: Select only one file to rename, or use MS-DOS
wildcards (for example, *.txt) to rename a group of files with similar
names.

Winamp similarly fails trying to access the file, so it appears as if
only the basic stat information is available to the client.

        I did not try changing my locale, so I cannot say whether this
would help.
Comment 1 Jeremy Allison 2006-06-24 13:34:14 UTC
Question marks in names are invalid Windows filenames.
The only way you'll ever be able to get to these is with mangled names = yes.

This is not a bug - this is by design. If you turn off name mangling, we report invalid Windows names but the client won't let you get to them. Not a suprise.

This isn't a bug.

Jeremy.