Bug 3834 - Winbind service intermittantly stops
Winbind service intermittantly stops
Status: RESOLVED DUPLICATE of bug 4009
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.20a
x86 Linux
: P3 normal
: none
Assigned To: Guenther Deschner
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 04:40 UTC by Ian
Modified: 2007-02-09 17:46 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian 2006-06-14 04:40:05 UTC
I have two servers (a file store and an email server) where winbind intermittantly stops running. I have kept a log of these times, and examined them for a pattern. I beleive I have traced the fault on the email server to the time the kerberos ticket is renewed. I have adjusted the time
as follows
   ticket_lifetime = 36000
   renew_lifetime = 40000
This has slightly improved the reliability as it now renews two out of three times successfully. But on the third time winbind dies, if left samba eventually crashes. I have put a script in place which checks the winbind service and restarts it if it is not running.

I would appreciate any help or guidance in this matter.
Ian
Comment 1 Guenther Deschner 2006-06-14 11:18:54 UTC
Could you possibly
* test whether this is still the case with 3.0.23rc2
* provide us logfiles, gdb backtraces ? 

Comment 2 Ian 2006-06-19 02:50:10 UTC
* test whether this is still the case with 3.0.23rc2
* provide us logfiles, gdb backtraces ? 

I will download and install 3.0.23rc2 hopefully today. 
I am fairly new to linux, please could you tell me which logfiles you require, where do I send them too. 
How do I get a gdb backtrace?

Ian
Comment 3 Ian 2006-06-19 03:33:36 UTC
I will not be upgrading to samba 3.0.23rc2 as this release says it is not for production servers.
Comment 4 Jeremy Allison 2006-06-19 10:42:57 UTC
We're not asking you to update to 3.0.23RC code on production servers, but to test it on non-production ones. That way you're helping us get it ready for production use.
Thanks,
Jeremy.
Comment 5 Guenther Deschner 2007-02-09 17:46:16 UTC
The tgt != tgs ticket lifetime has been adressed in bug #4009 and will be available in 3.0.25 (or your vendor picks up the patch earlier).

*** This bug has been marked as a duplicate of 4009 ***