Bug 3820 - Invalid error message when adding driver with insufficent space
Invalid error message when adding driver with insufficent space
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.20
Other Windows 2000
: P3 minor
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-01 15:34 UTC by Joanna Chan
Modified: 2012-01-09 10:39 UTC (History)
0 users

See Also:


Attachments
Level 10 samba.log (25.32 KB, application/x-zip-compressed)
2006-06-05 09:15 UTC, Joanna Chan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joanna Chan 2006-06-01 15:34:55 UTC
When the destination print server is 100% full, i.e. without space to further download any new driver.  If the user still go to the Print Server Properties page and add another driver, an error message will be displayed but it does not indicate the actual disk space error.

Different error message will be displayed based on Windows client version, some are like these:
1. Windows was unable to save all the date for the file .... This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

2. The driver that you are trying to install is not compitable with Windows XP Please contact the manufacturer for an updated version.

3. Unable to install Cannon ..., Windoes 95, ... Intel driver.  The driver that you are trying to install is not compitable with Windows XP.
Comment 1 Jeremy Allison 2006-06-02 18:46:07 UTC
Can you please upload a debug level 10 smbd log of this taking place (trying to add a driver to a disk with insufficient room). That will help debug this.
Jeremy.
Comment 2 Joanna Chan 2006-06-05 09:15:48 UTC
Created attachment 1942 [details]
Level 10 samba.log
Comment 3 Andreas Schneider 2012-01-09 10:39:31 UTC
This is probably fixed with a newer Samba version. If you still see the error. Please open a new bug with 'debug level = 10' logfiles of the new Samba version 3.5 or 3.6. Thanks!