Bug 380 - Getting compiler error on Samba3.0rc2 when compiling CP850.c
Getting compiler error on Samba3.0rc2 when compiling CP850.c
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Extended Characters
3.0.0preX
Other Solaris
: P2 major
: none
Assigned To: Alexander Bokovoy
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-01 01:23 UTC by Patrik Gustavsson
Modified: 2005-08-24 10:19 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrik Gustavsson 2003-09-01 01:23:34 UTC
Using Sun ONE 8 Compiler on Solaris 9.

When make is compile CP850.c the following errors is recived:

Compiling modules/CP850.c with -KPIC
"modules/CP850.c", line 27: syntax error before or at: [
Comment 1 Tim Potter 2003-09-01 02:22:10 UTC
Alexander, I suspect the syntax you use is not compatible with non-gcc compilers.
Comment 2 Tim Potter 2003-09-01 02:22:37 UTC
cc me
Comment 3 Alexander Bokovoy 2003-09-01 04:40:23 UTC
Fixed in CVS SAMBA_3_0:
1. We use now conventional syntax without indexing
2. charset module's generation code is changed accordingly
Comment 4 Gerald (Jerry) Carter 2005-02-07 09:06:29 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 5 Gerald (Jerry) Carter 2005-08-24 10:19:05 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.