Bug 3794 - samba 3.023pre1 + windows vista
samba 3.023pre1 + windows vista
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
3.0.23
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-22 01:14 UTC by Feroz Ahmed
Modified: 2007-02-08 16:10 UTC (History)
0 users

See Also:


Attachments
the file attached is the network trace (Ethereal logs) taken when connecting to windows vista from linux machine with samba 3.0.23pre1. (1.08 KB, application/octet-stream)
2006-05-22 02:05 UTC, Feroz Ahmed
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Feroz Ahmed 2006-05-22 01:14:37 UTC
Hi

We are using samba “samba-3.0.23pre1” when we try to connect “ Windows Vista, Beta 2, Version 6,Build 5308 ” we are getting the following error  

"session setup failed: SUCCESS - 0."
we tried with samba 2 its is working fine for windows vista.
the logs are as follows..



[root@linuz bin]# pwd

/usr/local/samba3023pre1/bin

[root@linuz bin]# ./smbclient -L Windows_Vista  -U wipro -d 10

INFO: Current debug levels:

  all: True/10

  tdb: False/0

  printdrivers: False/0

  lanman: False/0

  smb: False/0

  rpc_parse: False/0

  rpc_srv: False/0

  rpc_cli: False/0

  passdb: False/0

  sam: False/0

  auth: False/0

  winbind: False/0

  vfs: False/0

  idmap: False/0

  quota: False/0

  acls: False/0

  locking: False/0

  msdfs: False/0

  dmapi: False/0

lp_load: refreshing parameters

Initialising global parameters

params.c:pm_process() - Processing configuration file
"/usr/local/samba3023pre1/lib/smb.conf"

Processing section "[global]"

doing parameter workgroup = workgroup

doing parameter netbios name = smba_3_0_23_pre1

handle_netbios_name: set global_myname to: SMBA_3_0_23_PRE1

doing parameter encrypt passwords = yes

doing parameter server string = Samba 3...

doing parameter security = user

doing parameter username map = /etc/samba/smbusers

doing parameter smb passwd file = /etc/samba/smbpasswd

doing parameter log level = 10

doing parameter syslog = 0

doing parameter log file = /var/log/samba/%m

doing parameter max log size = 50

doing parameter Printcap name = CUPS

doing parameter printing = cups

doing parameter map to guest = Bad User

doing parameter server signing = Auto

doing parameter client signing = Auto

pm_process() returned Yes

lp_servicenumber: couldn't find homes

set_server_role: role = ROLE_STANDALONE

Attempting to register new charset UCS-2LE

Registered charset UCS-2LE

Attempting to register new charset UTF-16LE

Registered charset UTF-16LE

Attempting to register new charset UCS-2BE

Registered charset UCS-2BE

Attempting to register new charset UTF-16BE

Registered charset UTF-16BE

Attempting to register new charset UTF8

Registered charset UTF8

Attempting to register new charset UTF-8

Registered charset UTF-8

Attempting to register new charset ASCII

Registered charset ASCII

Attempting to register new charset 646

Registered charset 646

Attempting to register new charset ISO-8859-1

Registered charset ISO-8859-1

Attempting to register new charset UCS2-HEX

Registered charset UCS2-HEX

Substituting charset 'UTF-8' for LOCALE

Substituting charset 'UTF-8' for LOCALE

Substituting charset 'UTF-8' for LOCALE

Substituting charset 'UTF-8' for LOCALE

Substituting charset 'UTF-8' for LOCALE

Substituting charset 'UTF-8' for LOCALE

Substituting charset 'UTF-8' for LOCALE

Substituting charset 'UTF-8' for LOCALE

Substituting charset 'UTF-8' for LOCALE

Substituting charset 'UTF-8' for LOCALE

Substituting charset 'UTF-8' for LOCALE

Substituting charset 'UTF-8' for LOCALE

Substituting charset 'UTF-8' for LOCALE

Substituting charset 'UTF-8' for LOCALE

Substituting charset 'UTF-8' for LOCALE

Substituting charset 'UTF-8' for LOCALE

Substituting charset 'UTF-8' for LOCALE

Substituting charset 'UTF-8' for LOCALE

Substituting charset 'UTF-8' for LOCALE

Substituting charset 'UTF-8' for LOCALE

added interface ip=10.101.65.156 bcast=10.101.65.255 nmask=255.255.255.0

Netbios name list:-

my_netbios_names[0]="SMBA_3_0_23_PRE1"

Client started (version 3.0.23pre1).

internal_resolve_name: looking up Windows_Vista#20

Opening cache file at /usr/local/samba3023pre1/var/locks/gencache.tdb

Returning valid cache entry: key = NBT/WINDOWS_VISTA#20, value =
10.101.65.65:0, timeout = Tue May  9 15:24:55 2006

name Windows_Vista#20 found.

Connecting to 10.101.65.65 at port 445

socket option SO_KEEPALIVE = 0

socket option SO_REUSEADDR = 0

socket option SO_BROADCAST = 0

socket option TCP_NODELAY = 1

socket option TCP_KEEPCNT = 9

socket option TCP_KEEPIDLE = 7200

socket option TCP_KEEPINTVL = 75

socket option IPTOS_LOWDELAY = 0

socket option IPTOS_THROUGHPUT = 0

socket option SO_SNDBUF = 16384

socket option SO_RCVBUF = 87380

socket option SO_SNDLOWAT = 1

socket option SO_RCVLOWAT = 1

socket option SO_SNDTIMEO = 0

socket option SO_RCVTIMEO = 0

 session request ok

write_socket(4,183)

write_socket(4,183) wrote 183

got smb length of 149

size=149

smb_com=0x72

smb_rcls=0

smb_reh=0

smb_err=0

smb_flg=136

smb_flg2=55297

smb_tid=0

smb_pid=27521

smb_uid=0

smb_mid=1

smt_wct=17

smb_vwv[ 0]=    8 (0x8)

smb_vwv[ 1]= 2563 (0xA03)

smb_vwv[ 2]=  256 (0x100)

smb_vwv[ 3]= 1024 (0x400)

smb_vwv[ 4]=   17 (0x11)

smb_vwv[ 5]=    0 (0x0)

smb_vwv[ 6]=  256 (0x100)

smb_vwv[ 7]=    0 (0x0)

smb_vwv[ 8]=    0 (0x0)

smb_vwv[ 9]=64768 (0xFD00)

smb_vwv[10]=  995 (0x3E3)

smb_vwv[11]=26240 (0x6680)

smb_vwv[12]=57727 (0xE17F)

smb_vwv[13]=19871 (0x4D9F)

smb_vwv[14]=50803 (0xC673)

smb_vwv[15]=41985 (0xA401)

smb_vwv[16]=    1 (0x1)

smb_bcc=80

[000] 62 40 54 E4 CF 35 D4 4E  BA F9 90 01 9E 32 38 EF  b@T..5.N .....28.

[010] 60 3E 06 06 2B 06 01 05  05 02 A0 34 30 32 A0 30  `>..+... ...402.0

[020] 30 2E 06 09 2A 86 48 82  F7 12 01 02 02 06 09 2A  0...*.H. .......*

[030] 86 48 86 F7 12 01 02 02  06 0A 2A 86 48 86 F7 12  .H...... ..*.H...

[040] 01 02 02 03 06 0A 2B 06  01 04 01 82 37 02 02 0A  ......+. ....7...

size=149

smb_com=0x72

smb_rcls=0

smb_reh=0

smb_err=0

smb_flg=136

smb_flg2=55297

smb_tid=0

smb_pid=27521

smb_uid=0

smb_mid=1

smt_wct=17

smb_vwv[ 0]=    8 (0x8)

smb_vwv[ 1]= 2563 (0xA03)

smb_vwv[ 2]=  256 (0x100)

smb_vwv[ 3]= 1024 (0x400)

smb_vwv[ 4]=   17 (0x11)

smb_vwv[ 5]=    0 (0x0)

smb_vwv[ 6]=  256 (0x100)

smb_vwv[ 7]=    0 (0x0)

smb_vwv[ 8]=    0 (0x0)

smb_vwv[ 9]=64768 (0xFD00)

smb_vwv[10]=  995 (0x3E3)

smb_vwv[11]=26240 (0x6680)

smb_vwv[12]=57727 (0xE17F)

smb_vwv[13]=19871 (0x4D9F)

smb_vwv[14]=50803 (0xC673)

smb_vwv[15]=41985 (0xA401)

smb_vwv[16]=    1 (0x1)

smb_bcc=80

[000] 62 40 54 E4 CF 35 D4 4E  BA F9 90 01 9E 32 38 EF  b@T..5.N .....28.

[010] 60 3E 06 06 2B 06 01 05  05 02 A0 34 30 32 A0 30  `>..+... ...402.0

[020] 30 2E 06 09 2A 86 48 82  F7 12 01 02 02 06 09 2A  0...*.H. .......*

[030] 86 48 86 F7 12 01 02 02  06 0A 2A 86 48 86 F7 12  .H...... ..*.H...

[040] 01 02 02 03 06 0A 2B 06  01 04 01 82 37 02 02 0A  ......+. ....7...

Password:

Doing spnego session setup (blob length=80)

SPNEGO login failed: Unexpected information received

lang_tdb_init: /usr/local/samba3023pre1/lib/en_US.UTF-8.msg: No such file
or directory

session setup failed: SUCCESS - 0

[root@linuz bin]#
Comment 1 Feroz Ahmed 2006-05-22 02:05:18 UTC
Created attachment 1913 [details]
the file attached is the network trace (Ethereal logs) taken when connecting to windows vista from linux machine with samba 3.0.23pre1.
Comment 2 Jason Haar 2006-07-03 23:18:59 UTC
me too.

I have tried the official samba-3.0.22 under Fedora Core 5, and also compiled and installed samba-3.0.23rc3 with the same result. 

smbclient CRASHES when attempting to connect to a Vista workstation (member of same win2003 domain as Samba box). Build details:

ultimate version 6.0, build 5456.5.x86fre.winmain_idx03.060620-1700

Crash details are:

*** glibc detected *** smbclient: free(): invalid pointer: 0xbffbfd7c ***
======= Backtrace: =========
/lib/libc.so.6[0x207f18]
/lib/libc.so.6(__libc_free+0x78)[0x20b3ef]
smbclient(spnego_parse_negTokenInit+0x178)[0x8fc778]
smbclient(cli_session_setup_spnego+0x1ec)[0x8f305c]
smbclient(cli_session_setup+0x118f)[0x8f4e9f]
smbclient[0x908a04]
smbclient(cli_cm_open+0x85)[0x908ef5]
smbclient(main+0xb8b)[0x8b9e7b]
/lib/libc.so.6(__libc_start_main+0xdc)[0x1b9724]
smbclient[0x8b33f1]
Comment 3 Joakim Plate 2006-08-07 06:08:55 UTC
Just thought i'd post this here. I'm not 100% sure this is the same bug, but according to one of our users, these local policy changes made libsmbclient 2.0.22 access a vista beta 2 server. 

>Network access: Allow anonymous SID/name translation: Change to Enable
>Network access: Do not allow anonymous enumeration of SAM accounts - Change to Disabled
>Network access: Do not allow anonymous enumeration of SAM accounts and shares - Change to Disabled
>Network access: Let Everyone permissions apply to anonymous users - Change to Enable
>Network access: Restrict anonymous access to Named Pipes and Shares - Change to Disabled
>Network access: Shares that can be accessed anonymously - I added my root share name here
>Network access: LAN Manager authentication level - Change to LM & NTLM, send NTLMv2 if negotiated

It's just copy and pasted from his report, will have a look what the default values are at some point. I'm pretty sure not all those changes are required, but it might help somebody. 

I suspect the issue is with the "LAN Manager authentication Level", wich may be set to a mode that is incompatible with samba currently.
Comment 4 Joakim Plate 2006-08-07 11:37:41 UTC
Here are the default vista values

Network access: Allow anonymous SID/name translation: Disabled
Network access: Do not allow anonymous enumeration of SAM accounts: Enabled
Network access: Do not allow anonymous enumeration of SAM accounts and shares: Disabled
Network access: Let Everyone permissions apply to anonymous users: Disabled
Network access: Restrict anonymous access to Named Pipes and Shares: Enabled
Network access: Shares that can be accessed anonymously: Empty
Network access: LAN Manager authentication level: Send NTLMv2 response only

Comment 5 Gerald (Jerry) Carter 2007-02-08 16:10:16 UTC
Both connecting from Vista Ultimate to Samba 2.0.24 + the 
current patchset linked on the Feb 8 Bug day 
(http://wiki.samba.org/index.php/Bugzilla_Day) and connecting
top Vista from smbclient work fine.  SO I'll close this bug.

Note that connecting to Vista from smbclient using the -k flag 
does not work right now.  Instead you get the error:

   ads_krb5_mk_req: krb5_get_credentials failed for
   not_defined_in_RFC4178@please_ignore (Server not 
   found in Kerberos database)

That's separate issue.