Bug 379 - make hangs
make hangs
Status: RESOLVED DUPLICATE of bug 374
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.0preX
Other other
: P3 normal
: none
Assigned To: Tim Potter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-01 00:52 UTC by Suresh Khatry
Modified: 2005-02-07 09:06 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Suresh Khatry 2003-09-01 00:52:52 UTC
after successfully running a configure, execution of make hangs at the following
statement:

creating /var/tmp/samba-3.0.0rc1/source/include/proto.h

The following is the output when executing a make:

Using FLAGS =  -g -O2 -I./popt -Iinclude
-I/var/tmp/samba-3.0.0rc1/source/include -I/var/tmp/samba-3.0.0rc1/source/ubiqx
-I/var/tmp/samba-3.0.0rc1/source/smbwrapper  -I. -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -I/var/tmp/samba-3.0.0rc1/source
      LIBS = -lsendfile -lsec -lgen -lresolv -lsocket -lnsl -ldl
      LDSHFLAGS = -G
      LDFLAGS =
Building include/proto.h
creating /var/tmp/samba-3.0.0rc1/source/include/proto.h

A check of the processes shows the following:

root 13025 13024  0 12:30:41 pts/1    0:00 /bin/sh
/var/tmp/samba-3.0.0rc1/source/script/mkproto.sh gawk -h _PROTO_H_ /var
root 13034 13025  0 12:30:41 pts/1    0:00 gawk -v headername=_PROTO_H_ -f
script/mkproto.awk

Have got same result with GNU Awk 3.1.1 & 3.1.0 on a Sparc 10 and a Sparc V120
running Solaris 7, 8 & 9.

GCC version 2.8.1 & 3.3, GNU Make 3.8
Comment 1 Tim Potter 2003-09-01 02:27:09 UTC

*** This bug has been marked as a duplicate of 374 ***
Comment 2 Gerald (Jerry) Carter 2005-02-07 09:06:15 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.