Bug 3776 - smbd crashed when run on interactive mode
smbd crashed when run on interactive mode
Status: CLOSED REMIND
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
3.0.22
Other Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-15 01:33 UTC by Nataraj
Modified: 2006-05-16 07:37 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nataraj 2006-05-15 01:33:45 UTC
./smbd -i -d 10
-i    Interactive mode
-d 10 Debug level 10

I am trying to understand the handshaking mechnism indetail between samaba client and server so i was trying with interactive mode and debug mode. but smbd crashed after some time or when credentials username/password is supplied to access the share.

Log messages seen are :
run_events: No events
read_data: read of 4 returned 0. Error = Success
receive_smb_raw: length < 0!
timeout_processing: End of file from client (client has disconnected).
Closing cache file
namecache_shutdown: netbios namecache closed successfully.
Comment 1 Gerald (Jerry) Carter 2006-05-16 07:19:35 UTC
smbd didn't crash.  The client disconnected.

timeout_processing: End of file from client (client has disconnected).
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Comment 2 Nataraj 2006-05-16 07:26:53 UTC
Its crashed,
Please find the messages after the server has crashed.

[root@ProtocolStacks sbin]# ./smbd -i -d 10 > /root/UML/samba-3.0.22/TESTING/TRACES/INTERACTIVE/ipadd_auth_logon/smbd_i_d_10
talloc report on 'null_context' (total 2827 bytes in 76 blocks)
        struct service_control_op      contains     77 bytes in   5 blocks
        SORTED_TREE                    contains    527 bytes in  44 blocks
        pdb_context internal allocation context contains   1647 bytes in   7 blocks
        passdb internal SAM_ACCOUNT allocation contains    576 bytes in  19 blocks


[root@ProtocolStacks sbin]# ./smbd -i -d 10 > /root/UML/samba-3.0.22/TESTING/TRACES/INTERACTIVE/ipadd_auth_logon/smbd_i_d_10
talloc report on 'null_context' (total 2827 bytes in 76 blocks)
        struct service_control_op      contains     77 bytes in   5 blocks
        SORTED_TREE                    contains    527 bytes in  44 blocks
        pdb_context internal allocation context contains   1647 bytes in   7 blocks
        passdb internal SAM_ACCOUNT allocation contains    576 bytes in  19 blocks
[root@ProtocolStacks sbin]#
[root@ProtocolStacks ipadd_auth_logon]# 


Comment 3 Gerald (Jerry) Carter 2006-05-16 07:37:13 UTC
no it didn't crash.  In Samba 3.0.x, `smbd -i` handles one connmection an exits.
This is currently by design.