Bug 377 - broken national characters
broken national characters
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: Extended Characters
3.0.0preX
All Linux
: P3 normal
: none
Assigned To: Alexander Bokovoy
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-31 02:40 UTC by Tang Siu Hong
Modified: 2005-02-07 09:06 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tang Siu Hong 2003-08-31 02:40:48 UTC
My samba shares contains files with national characters names (big5 encoding 
chinese).  This work great with samba 2.2.7, except I can't use unicode file 
names.

After I upgrade to 3.0.0rc2, I can read/write unicode file names to the samba 
share.  However, the old files with big5 name is seen as broken names and 
become unaccessible.  Further, when listing the directory with these files, 
smbd process goes to 99% CPU utilization for half minutes, with some error 
messages in log file (attached).

Should there be some "smart" checking for whether the file is encoded in UTF-8 
or national encodings?

Here's the related setting in smb.conf
        unicode = yes
        unix charset = UTF-8

I use Redhat 7.3 RPM binaries of samba-3.0.0rc2 with
gcc-3.2.2-5
glibc-2.3.2-11.9

thanks.  please state what further information i have to provided.


log file:
[2003/08/31 16:55:43, 1] smbd/service.c:make_connection_snum(692)
  bobo (192.168.0.2) connect to service data initially as user shtang (uid=500, 
gid=503) (pid 29556)
[2003/08/31 16:56:17, 1] smbd/service.c:make_connection_snum(692)
  bobo (192.168.0.2) connect to service shtang initially as user shtang 
(uid=500, gid=503) (pid 29556)
[2003/08/31 16:56:28, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2003/08/31 16:56:28, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 29556 (3.0.0rc2)
  Please read the appendix Bugs of the Samba HOWTO collection
[2003/08/31 16:56:28, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2003/08/31 16:56:28, 0] lib/util.c:smb_panic(1462)
  PANIC: internal error
[2003/08/31 16:56:28, 0] lib/util.c:smb_panic(1469)
  BACKTRACE: 15 stack frames:
   #0 smbd(smb_panic+0x14e) [0x818e99e]
   #1 smbd [0x817ee27]
   #2 /lib/libc.so.6 [0x4027bc18]
   #3 /lib/libc.so.6 [0x402c2209]
   #4 /lib/libc.so.6(malloc+0x90) [0x402c1494]
   #5 smbd(Realloc+0x6d) [0x818dfed]
   #6 smbd [0x80a4a2b]
   #7 smbd(reply_trans2+0x712) [0x80ab052]
   #8 smbd [0x80bc319]
   #9 smbd [0x80bc3be]
   #10 smbd(process_smb+0x1a7) [0x80bc6c7]
   #11 smbd(smbd_process+0x1c1) [0x80bd101]
   #12 smbd(main+0x6c3) [0x81e8b73]
   #13 /lib/libc.so.6(__libc_start_main+0xa9) [0x4026a49d]
   #14 smbd(chroot+0x35) [0x8076261]
[2003/08/31 16:56:28, 1] smbd/service.c:make_connection_snum(692)
  bobo (192.168.0.2) connect to service data initially as user shtang (uid=500, 
gid=503) (pid 29558)
[2003/08/31 17:06:30, 1] smbd/service.c:make_connection_snum(692)
  bobo (192.168.0.2) connect to service shtang initially as user shtang 
(uid=500, gid=503) (pid 29558)
[2003/08/31 17:06:44, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2003/08/31 17:06:44, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 29558 (3.0.0rc2)
Comment 1 Alexander Bokovoy 2003-08-31 04:46:35 UTC
There is no way to detect encoding which was used to name a file on POSIX file
system as such system does not have a property 'encoding'. This is configuration
issue, not a bug in Samba.

Either set up
   unix charset = big5
and continue to encode file names with BIG5, or convert your file names to UTF-8
before using Samba 3.0.
Comment 2 Gerald (Jerry) Carter 2005-02-07 09:06:18 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.