Bug 375 - Many messages 'Error loading module .../lib/charset/646.so' when no locale available
Many messages 'Error loading module .../lib/charset/646.so' when no locale av...
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Extended Characters
3.0.0preX
All Solaris
: P4 minor
: none
Assigned To: Tim Potter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-29 18:01 UTC by Edgar Hoch
Modified: 2005-11-14 09:29 UTC (History)
2 users (show)

See Also:


Attachments
Quieten debugs on smb_probe_module() (2.28 KB, patch)
2003-09-03 19:04 UTC, Tim Potter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Edgar Hoch 2003-08-29 18:01:43 UTC
I downloaded Samba 3.0.0rc2 and compiled it on Sun Solaris 8 with gcc 2.95.2.
I used
    env CFLAGS=-O2 LDFLAGS=-s CC=gcc ./configure  --prefix=/opt/samba
--with-configdir=/etc/samba --with-piddir=/var/run --with-lockdir=/var/run
--with-logfilebase=/var/log --with-privatedir=/var/samba/private
--with-swatdir=/opt/samba/swat --with-automount --with-pam --with-quotas
--with-acl-support --with-libiconv=/usr/local
gmake all

and installed it in /opt (doesn't really matter, just for completeness).

Whenever I started the daemons (smbd, nmbd), then there are 10 log messages
for each started daemon (and again after changing smb.conf)
like the following:

[2003/08/30 02:04:55, 0] lib/module.c:smb_load_module(40)
  Error loading module '/opt/samba/lib/charset/646.so': ld.so.1:
/opt/samba/sbin/smbd: fatal: /opt/samba/lib/charset/646.so: open failed: No such
file or directory
[2003/08/30 01:43:17, 0] lib/module.c:smb_load_module(40)
  Error loading module '/opt/samba/lib/charset/646.so': ld.so.1:
/opt/samba/sbin/nmbd: fatal: /opt/samba/lib/charset/646.so: open failed: No such
file or directory

Also most client programs (in bin dir) gives nearly the same message:

Error loading module '/opt/samba/lib/charset/646.so': ld.so.1:
/opt/samba/bin/smbstatus: fatal: /opt/samba/lib/charset/646.so: open failed: No
such file or directory

This happens only if environment variables for locales (LANG, LC_ALL, etc) are
set or are set but there exists no file
/usr/local/share/locale/LOCALE/LC_MESSAGES/libiconv.mo
where LOCALE should be replaced by the value of the appropriate environment
variable. When I set LANG=de (for example) then no such error messages appear.

I don't know if the reason is in libiconv (I have installed GNU libiconv 1.9.1).
But I suppose that each program should do reasonable defaults when the active
locale is not available. May be the default is to use the ISO 646 charset, but
the file 646.so is not supplied.

The programs print the error messages (and make the output not very readable),
but otherwise runs normal. I have a problem with printer access from Windows
2000 and XP hosts to Solaris samba server, but I assume there is another reason
(may be in the configuration). (When testing with rpcclient the command
'openprinter printer' the result is WERR_ACCESS_DENIED, but the getprinter
command prints fine results.)

So there is no really need to fix it, but it may confuse other users. If you
have time and know who to fix it then it would be best done before releasing the
final version.

Many thanks, and best regards

Edgar
Comment 1 Tim Potter 2003-08-31 05:09:31 UTC
Changing the component to 'Extended Characters'.  I don't think this is a build
problem, but rather either a modules or i18n problem.
Comment 2 Brian Poole 2003-09-03 14:12:21 UTC
This bug affects much more than Solaris. It is also highly annoying IMO and
makes samba3 darn near unusable. I would really like to install samba3 on our
Sun systems here to see if it helps with some random problems we have with samba
2.2, but I refuse to install a program that gives 20 lines of "errors" everytime
I run a program (in this case, smbclient.) Please bump the priority of this to
P1 or P2 because it really needs to be fixed to be usable for most people. This
problem can be seen on many OSes as well:

http://build.samba.org/?function=View+Build&host=pandemonium&tree=samba_3_0&compiler=cc
OpenBSD-current
http://build.samba.org/?function=View+Build&host=vlo&tree=samba_3_0&compiler=gcc
FreeBSD-5.0
http://build.samba.org/?function=View+Build&host=gc20&tree=samba_3_0&compiler=gcc
Solaris-2.6
http://build.samba.org/?function=View+Build&host=us4&tree=samba_3_0&compiler=cc
AIX-6.5

In my case I am building on Solaris 7. I see these errors whether I use GNU's
libiconv or not.
Comment 3 Tim Potter 2003-09-03 19:04:05 UTC
Created attachment 121 [details]
Quieten debugs on smb_probe_module()

I've checked in this patch.  Could you try it out and see if it solves your
problem?

It's basically a debug level cleanup for what I think your problem is.
Comment 4 Edgar Hoch 2003-09-05 19:21:15 UTC
I have tested the patch. It works. Now no such messages apper.

But I don't know if it only supresses the message and there may be a problem
when the library is not found. Please assign the right status to this bug.

Thank for your work!

Edgar
Comment 5 Brian Poole 2003-09-08 20:09:08 UTC
I can echo the experiences of Edgar. The messages are now thankfully silenced.
If they were indeed of import I would be concerned that it basically just tells
them to shut up now but I really have no knowledge of the charset libraries and
what exactly is going on here, so I won't comment on that.

Thanks for at least making them be quiet. I will be putting samba3 in as the
default in the next day or two, we shall see how it fairs then.
Comment 6 Brian King 2003-09-09 07:48:38 UTC
I was having no issue with these error messages with CVS code from 2003-08-25 
as long as I had the following in smb.conf:

   dos charset = ASCII
   display charset = ASCII

I just downloaded CVS code from 2003-09-08, and now the "testparm" program 
gives the error messages, but smbclient does not (i.e. smbclient is still ok).

===
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
creating default valid table
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: testparm: 
fatal: /usr/local/samba/lib/charset/646.so: open failed: No such file or 
directory
Failed to load /usr/local/samba/lib/valid.dat - No such file or directory
creating default valid table

Comment 7 Tim Potter 2003-09-10 15:40:32 UTC
Edgar and Mr Poole, it turned out to be a bogus error message (if you are
probing for something you shouldn't be surprised when it isn't there) so I
silenced it.

Mr King, I'll investigate the testparm issue today.

Thanks guys,

Tim.
Comment 8 Tim Potter 2003-09-10 18:54:39 UTC
Hmm - are you sure you are running the right version of testparm or have
forgotten to recompile testparm?  The smbclient and testparm programs should be
using the same code so the fix for this bug should work on both of them.
Comment 9 Brian King 2003-09-12 06:33:10 UTC
Definitely the right version of testparm:

bash-2.05# cd samba
bash-2.05# cvs update -d -P
bash-2.05# make realclean
bash-2.05# ./autogen.sh
bash-2.05# ./configure --with-ads --with-pam --with-pam_smbpass --with-quotas --
with-acl-support --with-winbind
bash-2.05# make include/proto.h
bash-2.05# make bin/testparm
bash-2.05# bin/testparm
Load smb config files from /usr/local/samba/lib/smb.conf
creating lame upcase table
creating lame lowcase table
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
creating default valid table
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
Error loading module '/usr/local/samba/lib/charset/646.so': ld.so.1: 
bin/testparm: fatal: /usr/local/samba/lib/charset/646.so: open failed: No such 
file or directory
Failed to load /usr/local/samba/lib/valid.dat - No such file or directory
creating default valid table
Processing section "[homes]"


**** Side note, notice the "make include/proto.h" above. include/proto.h is not 
listed as one of the dependancies for bin/testparm in Makefile.in, so it has to 
be manually requested to be built ****
Comment 10 Brian Poole 2003-09-13 09:21:04 UTC
testparm bit is confirmed here as well, complains loudly using rc4. smbclient is
nicely quiet though.

Error loading module '/usr/local/samba-3.0.0rc4/lib/charset/646.so': ld.so.1:
/usr/local/samba-3.0.0rc4/bin/testparm: fatal:
/usr/local/samba-3.0.0rc4/lib/charset/646.so: open failed: No such file or directory

Complains with that about 20+ times.
Comment 11 Tim Potter 2003-09-14 17:10:55 UTC
The prototype issue is a known problem with the Samba source.  I would like to
move away from automatically generated prototypes and force people to update
them by hand but tridge disagrees.
Comment 12 Tim Potter 2003-09-14 17:22:31 UTC
OK I've fixed most of the error messages.  If I set 'display charset = CP646' I
now only get these guys, unfortunately twice.

Conversion from UCS-2LE to CP646 not supported
Conversion from UTF-8 to CP646 not supported
Conversion from CP646 to UCS-2LE not supported
Conversion from CP646 to UTF-8 not supported
Conversion from CP646 to CP850 not supported
Conversion from CP646 to UTF8 not supported
Conversion from CP850 to CP646 not supported
Conversion from UTF8 to CP646 not supported
Comment 13 Tim Potter 2003-09-15 17:00:12 UTC
It looks like Alexander has checked in some code to fix the remaining 646
messages.  I might mark this closed!

Please re-open if you see any more problems.
Comment 14 Gerald (Jerry) Carter 2005-02-07 09:06:11 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 15 Gerald (Jerry) Carter 2005-08-24 10:18:52 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 16 Gerald (Jerry) Carter 2005-11-14 09:29:22 UTC
database cleanup