Bug 3745 - idmap_ad backend not workin with 2003R2 +SUA
idmap_ad backend not workin with 2003R2 +SUA
Status: RESOLVED DUPLICATE of bug 3345
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.20
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-02 01:57 UTC by laurent Bardi
Modified: 2006-05-02 02:49 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description laurent Bardi 2006-05-02 01:57:15 UTC
Hi,
The new SUA (ex-SFU) in 2003R2 has the capibility to give us uidNumber (oid 1.3.6.1.1.1.1.0)  and gidNumber (oid 1.3.6.1.1.1.1.1). But samba does not recognize them. Modifiyng idmap_ad should resolve the problem (template sfu does not work too)?. 

Nevertheless it should be nice to have the mapping "whereis_gid_number"  and "whereis_uid_number" as parameter in smb.conf (it could be file://; ldap://, script://, ...) and let the admin decide how the mapping is done ?
In that case the ldap:// could be the AD itself, an openldap database, or even an ADAM instance.



Many thanks in advance for all your great work.
Comment 1 Guenther Deschner 2006-05-02 02:49:31 UTC

*** This bug has been marked as a duplicate of 3345 ***