Bug 3737 - hide_unreadable hides many readable files
hide_unreadable hides many readable files
Status: NEW
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.22
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-28 10:27 UTC by Lucas Chiesa
Modified: 2007-05-07 08:40 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lucas Chiesa 2006-04-28 10:27:54 UTC
Hello!

We are using samba 3.0.22 (though we also tried with 2.0.21b with the same luck) as a PDC and file server in a network with Win 98, Win 2k and Linux clients.

The PDC part of the sever works fine with win 98 and win 2k. However, the file sharing worked very badly with Win 98. For example in a folder with 157 items, only 17 were shown, no matter what the names were, for example "hello" was hidden and "Professional Audio" no. Also, if I created a new file or folder from the windows client, it was created in the server and then instantly hidden to the Windows Explorer. However if I wrote the complete path, W.Explorer showed the content of the folder, so, it was readable.

For example, a folder that was showed in windows had the following permissions:
(I'm logged in with a user named "achiesa" which is in the "club_robotica" group)

drwsrwsr--   2 compartida club_robotica     4096 Apr 17 12:04 Brazo Acrilico

However this file, with the same exact permissions, was not shown:

drwsrwsr--   2 compartida club_robotica     4096 Apr 17 12:37 romax

A file created from windows had these permissions:

drwxrwsr--   2 achiesa    club_robotica     4096 Apr 28 11:27 hello

Notice that the owner is different, however the permissions are correct, because it has 774, and belongs to the same group. Nonetheless I changed the permissions to match exactly the ones of the showed file, and did not make any difference.

There were some cases in which some more files were shown with a somewhat erratic behaviour.

This problem was solved by changing

hide unreadable = yes to = no in the smb.conf

However, this was not the problem, because the files hidden were not unreadable. 
There is no problem using the "hide dot files" option.

So, to sum up, the problem is now fixed, but because 'hide unreadable' is set to no.  This does not make any sense and thus I'm reporting it as a bug.

Please ask me if you need some information about my system, like smb.conf, or any other thing in order to better trace the bug.

Thank you very much,

Lucas Chiesa
Comment 1 erich gutweniger 2007-05-07 08:40:53 UTC
same problem with ACL and hide unreadable option  hides too much
on SUSE Linux 2.6.4-52-smp

drwxrwx---+ 2 root root  48 May  7 15:28 usera/

sll:/smb/stuffer/tmp # getfacl *
# file: usera
# owner: root
# group: root
user::rwx
user:erich:rwx
group::rwx
mask::rwx
other::---

File usera is not visible to user erich