Bug 3695 - smbd panic on startup when samba private directory is missing
smbd panic on startup when samba private directory is missing
Status: RESOLVED DUPLICATE of bug 3696
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.22
x64 Linux
: P3 minor
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-17 15:59 UTC by Steve French
Modified: 2006-04-18 01:40 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve French 2006-04-17 15:59:31 UTC
When /usr/local/samba/private directory not created, smbd panics on start instead of gracefully exiting.

Failed to open /usr/local/samba/private/secrets.tdb
startsmbfilepwent_internal: file /usr/local/samba/private/smbpasswd did not exist. Couldn't create new one.                    Error was: No such file or directoryUnable to open passdb database.
Failed to open /usr/local/samba/private/secrets.tdb
Failed to open /usr/local/samba/private/secrets.tdb
pdb_generate_sam_sid: Failed to store generated machine SID.
smb_panic: clobber_region() last called from [secrets_init(62)]
PANIC (pid 3147): Could not generate a machine SID

BACKTRACE: 10 stack frames:
 #0 ./smbd(log_stack_trace+0x1a) [0x55555572dc0e]
 #1 ./smbd(smb_panic+0xb8) [0x55555572dad9]
 #2 ./smbd(get_global_sam_sid+0x2d) [0x5555556f52ef]
 #3 ./smbd(uid_to_sid+0x108) [0x55555570a085]
 #4 ./smbd(get_root_nt_token+0xa7) [0x55555576a3e1]
 #5 ./smbd(svcctl_init_keys+0x2e) [0x55555566598a]
 #6 ./smbd(init_registry+0xd5) [0x55555579b841]
 #7 ./smbd(main+0x4b4) [0x5555557a8b7a]
 #8 /lib64/tls/libc.so.6(__libc_start_main+0xda) [0x2b197588755a]
 #9 ./smbd [0x5555555aacba]
smb_panic(): calling panic action [/bin/sleep 999999999]
Comment 1 Volker Lendecke 2006-04-18 01:40:24 UTC

*** This bug has been marked as a duplicate of 3696 ***