Bug 3680 - New child processes spawned by wbinfo are never finished/stopped
New child processes spawned by wbinfo are never finished/stopped
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.20
Other Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
: 3681 3682 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-13 13:56 UTC by Leon Vernikov
Modified: 2006-04-14 12:19 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leon Vernikov 2006-04-13 13:56:24 UTC
The steps to reproduce
1. registered samba client (RPC join) with Windows NT4 server successfully
2. tested registration 
   # net rpc testjoin
   Join to 'NT4D2' is OK
3. started winbind daemon; 
authentication of users from NT4D2 domain is successful
4. samba version
  # wbinfo -V        
  Version 3.0.20
5. check the running winbind daemon
  # ps ax | grep win
  17413 ?        SNs    0:00 /usr/sbin/winbindd -Y -l /local/local1/errorlog
  17414 ?        SN     0:00 /usr/sbin/winbindd -Y -l /local/local1/errorlog
  17422 pts/0    R+     0:00 grep win
6. execute wbinfo with sequence flag
  # date
  Thu Apr 13 04:48:59 UTC 2006
  # wbinfo --sequence
  NT4D1 : DISCONNECTED
  CLIENT1 : 1
  BUILTIN : 1
  NT4D2 : 515
  # date
  Thu Apr 13 04:49:08 UTC 2006
  # ps ax | grep win
  17413 ?        SNs    0:00 /usr/sbin/winbindd -Y -l /local/local1/errorlog
  17414 ?        SN     0:00 /usr/sbin/winbindd -Y -l /local/local1/errorlog
  17506 ?        SN     0:00 /usr/sbin/winbindd -Y -l /local/local1/errorlog
  17507 ?        SN     0:00 /usr/sbin/winbindd -Y -l /local/local1/errorlog
  17508 ?        SN     0:00 /usr/sbin/winbindd -Y -l /local/local1/errorlog
  24508 pts/0    R+     0:00 grep win

Please, note 3 new child processes


# testparm -s
Load smb config files from /etc/samba/smb.conf
Processing section "[print$]"
Processing section "[printers]"
Loaded services file OK.
[global]
        workgroup = NT4D2
        security = DOMAIN
        password server = 192.168.1.42, *
        log level = winbind:5
        log file = /local/local1/errorlog/samba.log
        max log size = 1000
        smb ports = 50139
        lpq cache time = 10
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        printcap cache time = 60
        printcap name = cups
        preferred master = No
        local master = No
        domain master = No
        dns proxy = No
        wins server = 192.168.1.10
        idmap uid = 70000-200000
        idmap gid = 70000-200000
        template homedir = /local/local1/
        template shell = /admin-shell
        winbind cache time = 900
        winbind enum users = No
        winbind enum groups = No
        winbind use default domain = Yes
        cups options = "raw"
        default devmode = Yes
        force printername = Yes

[print$]
        path = /state/samba/printers
        write list = root
        guest ok = Yes

[printers]
        comment = All Printers
        path = /local/local1/spool/samba
        guest ok = Yes
        printable = Yes
        browseable = No
debugshell#
Comment 1 Gerald (Jerry) Carter 2006-04-13 14:01:36 UTC
*** Bug 3681 has been marked as a duplicate of this bug. ***
Comment 2 Gerald (Jerry) Carter 2006-04-13 14:02:09 UTC
This is normal.  The winbindd architecture has been redesigned.
Comment 3 Gerald (Jerry) Carter 2006-04-13 14:14:47 UTC
*** Bug 3682 has been marked as a duplicate of this bug. ***
Comment 4 Leon Vernikov 2006-04-14 11:57:31 UTC
(In reply to comment #2)
> This is normal.  The winbindd architecture has been redesigned.

Would you, please, provide a patch/bug id to resolve this issue in samba 3.0.20 code release?
 
Comment 5 Gerald (Jerry) Carter 2006-04-14 12:19:50 UTC
There is no patch.  There is no leak.  Like I said, this is 
the normal architecture post 3.0.20.  You will alwayds have 
more than 2 winbind processes.