Bug 3678 - nmbd/smbd doesn't start with glibc2.4
nmbd/smbd doesn't start with glibc2.4
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: nmbd
3.0.22
x86 Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-12 11:25 UTC by VOROSKOI Andras
Modified: 2006-05-19 10:38 UTC (History)
2 users (show)

See Also:


Attachments
fix against glibc2.4 (2.23 KB, patch)
2006-05-19 10:20 UTC, VOROSKOI Andras
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description VOROSKOI Andras 2006-04-12 11:25:33 UTC
root@kavics:~# /usr/sbin/nmbd -D
Aborted
root@kavics:~# /usr/sbin/smbd -D
Aborted

Here you can find the strace output:
http://frugalware.org/~voroskoi/strace_nmbd.out
Comment 1 Gerald (Jerry) Carter 2006-04-15 09:17:56 UTC
You compiled glibc 2.4 yourself didn't you?
Comment 2 VOROSKOI Andras 2006-04-15 09:27:26 UTC
No, i'm using frugalware-current package.

ftp://ftp.frugalware.org/pub/frugalware/frugalware-current/source/base/glibc

There you can find the FrugalBuild. I'm using the i686 version, so no patch have been used.

CFLAGS are -march=i686 -O2 -pipe

Let me know if you need any additional information!
Comment 3 Gerald (Jerry) Carter 2006-04-20 07:47:19 UTC
SuSE 10.1 uses glibc 2.4 without any problems.  Can you get a gdb 
back trace of smbd ?  This appears to be the same thing as BUG 3655.
Comment 4 Gerald (Jerry) Carter 2006-04-20 08:03:42 UTC
severity should be determined by the developers and not the reporter.
Comment 5 VOROSKOI Andras 2006-04-20 09:57:07 UTC
(In reply to comment #3)
> SuSE 10.1 uses glibc 2.4 without any problems.  Can you get a gdb 
> back trace of smbd ?  This appears to be the same thing as BUG 3655.
> 

(gdb) run
Starting program: /usr/sbin/smbd
(no debugging symbols found)

Program received signal SIGABRT, Aborted.
0xffffe410 in __kernel_vsyscall ()
(gdb) bt
#0  0xffffe410 in __kernel_vsyscall ()
#1  0xb7b35581 in ?? ()
#2  0xb7c27ff4 in ?? ()
#3  0xb7a0c6b0 in ?? ()
#4  0xbf857af0 in ?? ()
#5  0xb7b36be9 in ?? ()
#6  0x00000006 in ?? ()
#7  0xbf857a64 in ?? ()
#8  0x00000000 in ?? ()

So you think that it's a bug in our glibc?
Comment 6 Gerald (Jerry) Carter 2006-04-20 10:03:17 UTC
I haven't looked into it very deeply.  But that 
has been the conclusion of others.  I've copied Guenther
on this.  Perhaps he can offer some advice as to why
this is not seen on the SuSE glibc 2.4 builds.
Comment 7 VOROSKOI Andras 2006-04-21 07:09:58 UTC
Now i've recompiled glibc without -march=i686 -O2 -pipe, but the problem is still there. I've recompile samba as well, but didn't help.

I have no idea why does it work on suse, but BUG 3655 shows that there are problems on mandriva too.

Have you tried to use samba on suse with a clean (not full of patches) glibc build? Maybe you would be able to reproduce this problem.
Comment 8 Thomas Koeller 2006-04-23 18:43:00 UTC
I am encountering the same problem. My system has glibc-2.4, gcc-4.1.0 and Linux kernel 2.6.16, all built from source. Here's the output I receive when trying to start the daemons:

bash-3.1$ /sbin/nmbd -i -S
Netbios nameserver version 3.0.22 started.
Copyright Andrew Tridgell and the Samba Team 1992-2006
nmbd: gconv_db.c:232: __gconv_release_step: Assertion `step->__end_fct == ((void *)0)' failed.
===============================================================
INTERNAL ERROR: Signal 6 in pid 29554 (3.0.22)
Please read the Trouble-Shooting section of the Samba3-HOWTO

From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
===============================================================
PANIC: internal error
BACKTRACE: 1 stack frames:
 #0 /sbin/nmbd(smb_panic2+0x8a) [0x800a446a]
Aborted

bash-3.1$ /sbin/smbd -i -S
smbd version 3.0.22 started.
Copyright Andrew Tridgell and the Samba Team 1992-2006
smbd: gconv_db.c:232: __gconv_release_step: Assertion `step->__end_fct == ((void *)0)' failed.
===============================================================
INTERNAL ERROR: Signal 6 in pid 29555 (3.0.22)
Please read the Trouble-Shooting section of the Samba3-HOWTO

From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
===============================================================
PANIC: internal error
BACKTRACE: 1 stack frames:
 #0 /sbin/smbd(smb_panic2+0x8a) [0x8021451a]
Aborted
Comment 9 Wilco 2006-05-10 16:29:52 UTC
Same problems here using glibc-2.4, kernel 2.6.16.11 and gcc-4.1. All compiled from sources.
The weird thing is if I start smbd and nmbd while running in X, it starts up fine
Comment 10 Thomas Sauer 2006-05-11 05:52:58 UTC
And the same here on a new, clean LFS with glibc-2.4, Kernel 2.6.16-ck9 and gcc-4.1.0. I`ve tried  out samba-3.0.22 and 3.0.23-pre1.


 
Comment 11 VOROSKOI Andras 2006-05-19 10:20:37 UTC
Created attachment 1909 [details]
fix against glibc2.4
Comment 12 VOROSKOI Andras 2006-05-19 10:22:47 UTC
I've added a patch that works for me. IMO you can close this bug now.
Comment 13 Gerald (Jerry) Carter 2006-05-19 10:38:16 UTC
confirmed glibc bug.