Bug 3663 - Add a computer-account to a local group
Add a computer-account to a local group
Status: REOPENED
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.23c
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-06 03:40 UTC by Torsten
Modified: 2006-12-08 05:26 UTC (History)
0 users

See Also:


Attachments
Debug log. (225.28 KB, application/octet-stream)
2006-12-07 09:33 UTC, Torsten
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Torsten 2006-04-06 03:40:44 UTC
Hello!

I am using Windows 2003 R2 Server and wanted to add a computer-account to the local group "Session Directory Computers". 

I have used the the search function in the dialog and could choose the computer. It was listed (eg. DOMAIN\mycomputer), but when I pressed "OK" the error-message came: "Information returned from the object picker for object mycomputer was incomplete. The object will not be processed." And so I could not add the computer-account to the group.

I looked at my samba-configuration and the logs, but could not find anything.

For a second try I typed in the name of the computer including the trailing "$". (DOMAIN\mycomputer$). This worked fine, and windows stripped of the "$". It is looking fine now (even though I have not had the possebility to test / check the functionality).

I am guessing, but the problem may arise from the processing of the trailing "$" being in-compatible with windows.
Comment 1 Gerald (Jerry) Carter 2006-04-08 08:02:52 UTC
Works fine in the current SAMBA_3_0.  There's been a lot of work in 
this area.  Please retest against 3.0.23pre1 once that is released
(or against the current SAMBA_3_0 tree).
Comment 2 Torsten 2006-12-07 04:08:58 UTC
I have had time to do some testing on this one... Using Samba 3.0.23c on FedoraCore 5. All the rest is still the same -- including the problem.
Comment 3 Volker Lendecke 2006-12-07 04:12:23 UTC
Please submit debug level 10 logs of smbd when you try this.

Thanks,

Volker
Comment 4 Torsten 2006-12-07 09:33:51 UTC
Created attachment 2236 [details]
Debug log.

Here is a level 10 debug-log. 
The 1st part is where I used the "find" functionality and got the error-message. 
The 2nd part is where I typed in the computer name with a trailing "$".

Thanks,
     -- Torsten.
Comment 5 Volker Lendecke 2006-12-07 09:49:08 UTC
You seem to not have the primary group of the workstation account in your group mapping db. Please add a group mapping for the primary unix gid and retry.

Thanks,

Volker
Comment 6 Torsten 2006-12-07 10:02:37 UTC
Hmmm... I am not sure what to do.

The workstation has got the primary group "machines". This is mapped :

ntmachines (S-1-5-21-999321356-2110613833-829235722-516) -> machines

So from my understanding, the machine account has got a valid group ??

Thanks,

      -- Torsten.
Comment 7 Volker Lendecke 2006-12-07 10:22:11 UTC
Ok, another error that might lead to this is that your file /etc/passwd does not contain the BXTEST$ name in the right upper/lower case combination. Can you rename the user to BXTEST$ and retry?

Thanks,

Volker
Comment 8 Torsten 2006-12-08 05:24:24 UTC
Hi again!

I have re-astablished my test environment to ensure there are no side-effects. 
I have also re-named my computer account into uppercase letters (now called GIDEON$) -- but it still does not change the behaviour.

-- Torsten.
Comment 9 Volker Lendecke 2006-12-08 05:26:14 UTC
Sorry, then I'm out of ideas. I would need login to that box to find what's wrong.

Volker