Bug 3634 - nmbd should not segfault with bad interface line
nmbd should not segfault with bad interface line
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Client Tools
3.0.21c
Other Linux
: P3 minor
: 3.0.25
Assigned To: Jeremy Allison
Samba QA Contact
http://bugs.debian.org/359155
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-28 08:04 UTC by Christian Perrier
Modified: 2007-04-10 15:55 UTC (History)
0 users

See Also:


Attachments
Patch (580 bytes, patch)
2007-04-10 15:09 UTC, Jeremy Allison
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Perrier 2006-03-28 08:04:51 UTC
This bug is often reported in Debian. Several users mistakenly use the following in their smb.conf file:

       bind interfaces only = yes
       interfaces = 127.0.0.1

This is of course not really a good idea but it seems to make nmbd crash consistently.

We suggest that an error
message indicating the problem and then an orderly shutdown would be
more appropriate.

As written by Eloy Paris, one of the maitnainers: "Definitely not a bug in Samba, I agree, but there's definitely room for improvement here."
Comment 1 didier 2007-04-09 21:18:33 UTC
It's not exactly for the same reason but in ubuntu bug #100019:

5 0x080c17ac in sig_fault (sig=11) at lib/fault.c:42
#6 <signal handler called>
#7 find_workgroup_on_subnet (subrec=0x0, name=0x8136458 "WORKGROUP")
    at nmbd/nmbd_workgroupdb.c:177
#8 0x08076327 in write_browse_list (t=0, force_write=1)
    at nmbd/nmbd_serverlistdb.c:350
#9 0x0806261e in msg_reload_nmbd_services (msg_type=3001, src={pid = 0},
    buf=0xbfa72ee0, len=0) at nmbd/nmbd.c:314
Comment 2 Jeremy Allison 2007-04-10 15:09:56 UTC
Created attachment 2369 [details]
Patch

This should fix it for 3.0.25.
Jeremy.
Comment 3 Gerald (Jerry) Carter 2007-04-10 15:55:18 UTC
marking as fixed the next 3.0.25 snapshot.