Bug 3629 - ls does not show all files on smbfs mount
ls does not show all files on smbfs mount
Product: Samba 3.0
Classification: Unclassified
Component: File Services
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2006-03-24 06:27 UTC by Georg Lohmeyer
Modified: 2006-03-24 10:31 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Georg Lohmeyer 2006-03-24 06:27:41 UTC
i run a remote windows 2000 Computer with a USB disk attached. When I mount this disk as an smbfs share, the ls command won't show all files on that disk. In fact, the number of files shown differs from one run of ls to the other, sometimes the listing is complete, sometimes not. I searched the log files, but did not find any error messages. The Problen doesn't occur when I mount an Smb share from another linux server. The number of files is around 250, 2 to 3 are not shown. When I run a perl script which issues the readdir command, the same problem occurs. The files not shown have no special characteristics, do not begin with a dot, have no special characters in the name and are around 150 k size. When I run the DIR command from a second Windows machine via an UNC path, the files are shown correctly.
Comment 1 Jeremy Allison 2006-03-24 10:31:43 UTC
I'm sorry, smbfs is not a Samba project and we don't support it. I'd suggest trying CIFSFS instead.