Bug 3627 - Build on later AIX platforms fails to link for dynamic loads
Build on later AIX platforms fails to link for dynamic loads
Status: RESOLVED DUPLICATE of bug 1649
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.21c
Other AIX
: P3 normal
: none
Assigned To: William Jojo
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 07:52 UTC by Howard Wilkinson
Modified: 2006-04-10 06:27 UTC (History)
0 users

See Also:


Attachments
Patch configure for AIX late release (184 bytes, patch)
2006-03-23 07:52 UTC, Howard Wilkinson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Howard Wilkinson 2006-03-23 07:52:13 UTC
There have been a number of problems running Samba on AIX 5.3 reported by a number of people in various sites around the web.

At least one of the problems arises from a change in the linker options from a previous AIX release.

The current SVN for the configure script has a fix for this but it is not in the 3.0.21c release.

I enclose a patch that if applied to 3.0.21c with patch -p1 will set up the system to build correctly on such an AIX. This is obviously OS release dependent and I have not made any effort to fix for the different releases as I do not know when the change happened or how to determine which OS is running.
Comment 1 Howard Wilkinson 2006-03-23 07:52:56 UTC
Created attachment 1822 [details]
Patch configure for AIX late release
Comment 2 Gerald (Jerry) Carter 2006-04-08 11:34:12 UTC
Bill,  would you evaluate this patch when you get a chance?  Thanks.
Comment 3 William Jojo 2006-04-10 06:27:38 UTC
(In reply to comment #2)
> Bill,  would you evaluate this patch when you get a chance?  Thanks.

I believe the patch I submitted for #1649 is committed to TRUNK. This is essentially the same and this should be closed. :-)

Bill


*** This bug has been marked as a duplicate of 1649 ***