Bug 3604 - The smbd can't start with cups when the port 631 is used by another daemon.
Summary: The smbd can't start with cups when the port 631 is used by another daemon.
Status: RESOLVED WONTFIX
Alias: None
Product: Samba 3.0
Classification: Unclassified
Component: Printing (show other bugs)
Version: 3.0.21c
Hardware: x86 Linux
: P3 major
Target Milestone: none
Assignee: Gerald (Jerry) Carter
QA Contact: Samba QA Contact
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-14 04:04 UTC by TAKEDA yasuma
Modified: 2006-04-22 20:16 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description TAKEDA yasuma 2006-03-14 04:04:48 UTC
I find a problem about the initialization of smbd with CUPS.

If the port 631 is already used by a daemon(except cupsd), 
the smbd stops in the initialization. 

main()
 -> reload_service()
    -> reload_printers()
       -> pcap_cache_reload()
          -> cups_cache_reload()
             -> httpConnect()   
             -> cupsDoRequest()  
                  -> recv()      <--- STOP

If the port 631 is already used by another daemon,
httpConnect() succeeds.
And the recv() is executed in cupsDoRequest().
As a result, the smbd waits some responses forever.
Comment 1 Gerald (Jerry) Carter 2006-03-16 07:08:27 UTC
What are you running on port 631?  The current behavior is 
by design.  I don't see any timeout mechanism in the cupsDoRequest()
call.  You will need to file an issue with the cups developers.
Comment 2 TAKEDA yasuma 2006-04-04 01:39:30 UTC
I disabled the cups service.
And the NFS(rpc.rquotad) used the 631 port which is assigned by portmap by chance.
It caused our problem.

I filed this issue to CUPS's bugs. 
http://www.cups.org/str.php?L1535+P0+S-2+C0+I0+E0+Q

Thanks
Comment 3 Kurt Pfeifle 2006-04-22 20:16:22 UTC
Port 631 is a "well-known port" reserved for use by IPP servers only. Your NFS(rpc.rquotad) shows "illegal" behaviour in occupying that port