Bug 360 - Extended Character conversion can introduce raw unicode into 'unix' strings
Extended Character conversion can introduce raw unicode into 'unix' strings
Status: RESOLVED DUPLICATE of bug 830
Product: Samba 3.0
Classification: Unclassified
Component: Extended Characters
3.0.0preX
Other other
: P3 normal
: none
Assigned To: Jeremy Allison
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-27 15:40 UTC by Andrew Bartlett
Modified: 2005-02-07 09:06 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Bartlett 2003-08-27 15:40:41 UTC
The recent changes to extended character conversion support for nmbd can allow
all sorts of 'non unix' things into our unix strings.  It can also allow
unconverted unix strings into unicode bufferes, specificly those used for
StrCaseCmp() and fnmatch().  

At the very least, we should make StrCaseCmp() and fnmatch() check the errno,
but we shoul simply allow the conversion to fail, where we are in a position to
handle the erorr.
Comment 1 Andrew Bartlett 2004-02-03 23:38:05 UTC

*** This bug has been marked as a duplicate of 830 ***
Comment 2 Gerald (Jerry) Carter 2005-02-07 09:06:08 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.