Bug 358 - smb panic when converting strings
smb panic when converting strings
Product: Samba 3.0
Classification: Unclassified
Component: Extended Characters
All Linux
: P1 normal
: 3.0.0rc3
Assigned To: Jeremy Allison
Depends on:
  Show dependency treegraph
Reported: 2003-08-27 13:40 UTC by Mauricio Zambrano
Modified: 2005-11-14 09:29 UTC (History)
0 users

See Also:

screenshot of incorrectly displayed filename (83.58 KB, image/jpeg)
2003-08-29 08:48 UTC, Gerald (Jerry) Carter
no flags Details
config file for server (2.10 KB, text/plain)
2003-08-29 08:50 UTC, Gerald (Jerry) Carter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mauricio Zambrano 2003-08-27 13:40:05 UTC
smb panic when I have archive with names like:
Capítulo 04 - Organización del Procesador.ppt
the log file:
[2003/08/27 15:32:04, 1] smbd/service.c:make_connection_snum(692)
  black ( connect to service mauro initially as user mauro (uid=50
1, gid=500) (pid 6614)
[2003/08/27 15:32:06, 0] lib/charcnv.c:convert_string_allocate(272)
  Conversion error: Illegal multibyte sequence(ítulo 04 - Organización del Proce
[2003/08/27 15:32:06, 0] lib/util.c:smb_panic(1462)
  PANIC: failed to create UCS2 buffer
[2003/08/27 15:32:06, 0] lib/util.c:smb_panic(1469)
  BACKTRACE: 16 stack frames:
   #0 smbd(smb_panic+0xfc) [0x817f280]
   #1 smbd(unix_strupper+0x81) [0x816f30d]
   #2 smbd(strupper_m+0x48) [0x8179880]
   #3 smbd [0x80bef1e]
   #4 smbd [0x80bf5c7]
   #5 smbd(mangle_map+0x66) [0x80bdb52]
   #6 smbd [0x80a033c]
   #7 smbd [0x80a1904]
   #8 smbd(reply_trans2+0x5fc) [0x80a6db0]
   #9 smbd [0x80b8501]
   #10 smbd [0x80b8661]
   #11 smbd(process_smb+0x76) [0x80b8826]
   #12 smbd(smbd_process+0x198) [0x80b9334]
   #13 smbd(main+0x416) [0x81d2a62]
   #14 /lib/i686/libc.so.6(__libc_start_main+0xc7) [0x420158c7]
   #15 smbd(chroot+0x31) [0x8075c4d]
[2003/08/27 15:32:07, 1] smbd/service.c:make_connection_snum(692)

My local env is:
Comment 1 Gerald (Jerry) Carter 2003-08-28 09:34:57 UTC
should be fixed in latest SAMBA_3_0 cvs tree 
(to be included in 3.0.0rc2).  Please retest
Comment 2 Gerald (Jerry) Carter 2003-08-29 08:06:38 UTC
Marking it as fixed for RC2 (due to all the multibyte 
character set work).  Pleas reopen if that is not the case.
Comment 3 Gerald (Jerry) Carter 2003-08-29 08:47:19 UTC
From Mauricio Zambrano:

  I tried samba 3.0 CVS and it isnt crashing now but 
  the file name shows me squares instead of chars (as 
  shown on scrennshot.jpg). I could be my smb.conf but I 
  tried with dos charset = 850, CP850, ISO8859-1 and
  it shows me the same thing. I also tried to iconv the file 
  but it doesnt worked.
Comment 4 Gerald (Jerry) Carter 2003-08-29 08:48:16 UTC
Created attachment 111 [details]
screenshot of incorrectly displayed filename
Comment 5 Gerald (Jerry) Carter 2003-08-29 08:50:27 UTC
Created attachment 112 [details]
config file for server
Comment 6 Jeremy Allison 2003-08-29 11:21:49 UTC
This is a user misconfiguration. The dos character set can never be ISO8859-1,
Windows simply doesn't support that.

The correct config for western europe is :

dos charset = 850
unix charset = ISO8859-1

I'm pretty sure this is fixed - if RC2 works correctly for Japan, it's working
for Europe :-).

I'm marking this fixed unless the bug can be reproduced with the above settings.

Comment 7 Gerald (Jerry) Carter 2005-02-07 09:04:54 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 8 Gerald (Jerry) Carter 2005-08-24 10:26:23 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 9 Gerald (Jerry) Carter 2005-11-14 09:29:52 UTC
database cleanup