Bug 354 - import_smbpasswd.pl is broken in 3.0
import_smbpasswd.pl is broken in 3.0
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.0preX
Other other
: P3 normal
: 3.0.0rc2
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-26 07:24 UTC by Ming Deng
Modified: 2005-08-24 10:17 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ming Deng 2003-08-26 07:24:34 UTC
import_smbpasswd.pl does not work at all with samba3.0's new ldap schema file.
It still uses old samba schema.

If you don't mind, I can bring the script to a workable state as I did for myself.
Comment 1 Gerald (Jerry) Carter 2003-08-28 09:24:03 UTC
The import/export scripts are no longer needed.
Used the pdbedit -i and -e options.  See the 
man page for details.  I'm removing these scripts 
from the 3.0 tree.
Comment 2 Gerald (Jerry) Carter 2003-08-28 09:30:03 UTC
done
Comment 3 Gerald (Jerry) Carter 2005-02-07 09:06:18 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 4 Gerald (Jerry) Carter 2005-08-24 10:17:45 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.