Bug 3521 - mount.cifs does not use kerberos
mount.cifs does not use kerberos
Product: CifsVFS
Classification: Unclassified
Component: user space tools
Other Linux
: P3 normal
: ---
Assigned To: Steve French
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2006-02-17 06:08 UTC by Hadmut Danisch
Modified: 2006-05-03 02:14 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Hadmut Danisch 2006-02-17 06:08:30 UTC

I want to access a windows share with kerberos. E.g.

smbclient -L server -k

works as expected, it does not ask for a password and make use of the kerberos ticket. But when I try to mount a share with

mount.cifs //server/files /X -o sec=krb5

it ignores the ticket and still asks for a password ( Linux kernel)

Comment 1 Birger Wathne 2006-04-20 06:59:58 UTC
I am seeing the same problem using the cifs kernel module (1.40) and mount.cifs (1.10) that come with Fedora Core 5.

As I am working on a new standard linux client for our university it would be very nice to get cifs-mounting of home directories to use kerberos. smbmount works fine, but for obvious reasons cannot be used for linux home directories.
Comment 2 Birger Wathne 2006-05-02 09:54:10 UTC
After looking through the code for mount.cifs I tried using sec=krb5,guest as options. This keeps mount.cifs from asking about the password, but seems to only send sec=krb5 to the kernel module. Mounting still fails.
Comment 3 Lars Müller 2006-05-02 10:00:34 UTC
The kerberization of the cifs module is work in progress.  Steve talked about this topic at this years SambaXP conference.  Please stay tuned or if possible help him.
Comment 4 Birger Wathne 2006-05-03 02:14:21 UTC
The man page seems to imply it should have worked from kernel module version 1.39. Perhaps the man page should be revised until it actually works?

Where in the subversion tree can we find the latest sources for the kernel module? Just in case I find some time to look at it... And manage to make some sense of what I see :-)