Bug 3513 - Samba 3.0.21b does not honnor unix ACLs correctly
Summary: Samba 3.0.21b does not honnor unix ACLs correctly
Status: RESOLVED FIXED
Alias: None
Product: Samba 3.0
Classification: Unclassified
Component: File Services (show other bugs)
Version: 3.0.21b
Hardware: Sparc Solaris
: P3 critical
Target Milestone: none
Assignee: Gerald (Jerry) Carter
QA Contact: Samba QA Contact
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-14 06:52 UTC by Alain Chassot
Modified: 2006-02-14 07:42 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alain Chassot 2006-02-14 06:52:14 UTC
Samba 3.0.21b does not honnor unix ACLs correctly

On the unix server, we have:
getfacl Test.txt

# file: Test.txt
# owner: root
# group: root
user::r--
group::r-x		#effective:r-x
group:sysadmin:rwx		#effective:rwx
mask:rwx
other:---

Members of group sysadmin are not able to modifiy this file Test.txt with the latest version of Samba (3.0.21b). 
It works well with version 3.0.20b so we'll keep this old version on our servers
Users are connecting from WinXP machines

I hope you can fix this in the next version(s)
Comment 1 Gerald (Jerry) Carter 2006-02-14 06:56:51 UTC
It's more likely a read only attribute issue.  See the 'map read only' 
option in the smb.conf man page andlet me know if that helps.
Comment 2 Alain Chassot 2006-02-14 07:42:35 UTC
It semms it was not a bug, but a feature...

I've also added an "map read only = permissions" to the smb.conf file and it all works perfectly now

Thank you for the quick answer