Bug 3501 - problem with some characters (����) in filename
problem with some characters (����) in filename
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: Extended Characters
3.0.21b
x86 Windows 2000
: P3 normal
: none
Assigned To: Alexander Bokovoy
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-12 05:05 UTC by Dieter Ferdinand
Modified: 2011-03-21 08:06 UTC (History)
2 users (show)

See Also:


Attachments
configuration (5.71 KB, application/octet-stream)
2011-03-21 07:57 UTC, Dieter Ferdinand
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dieter Ferdinand 2006-02-12 05:05:40 UTC
hello,
i have problems with the character conversion and i use linux.

i must set characterset to cp450 for dos and unix, so that the characters 
Comment 1 Alexander Bokovoy 2007-05-22 06:08:38 UTC
Please re-test with 3.0.25, is it reproduceable?
Comment 2 Björn Jacke 2011-03-18 16:31:36 UTC
no feedback und most probably not a bug anymore -> WORKSFORME
Comment 3 Dieter Ferdinand 2011-03-20 19:28:49 UTC
hello,
actual installed Version 3.4.8

i make "md äöüÖÄÜ" under linux and get ______ under windows!
i make dir öäüÖÄÜ under windows and get öäüÃ?Ã?Ã? under linux!

smb.conf: dos charset = utf-8

goodby
Comment 4 Björn Jacke 2011-03-20 19:53:03 UTC
sorry, if you don't provide more information this is not helping us. "dos charset = utf-8" alone is not enough information. Furthermore - for win2000 dos charset is not relevant at all. I'm sure this is a misconfiguration issue.
If you need basic help setting up a samba server, consider to ask on the samba mailing list, bugzilla is not the right place.
Comment 5 Volker Lendecke 2011-03-20 21:26:02 UTC
In particular your full smb.conf and your locale settings are required.
Comment 6 Dieter Ferdinand 2011-03-21 07:57:37 UTC
Created attachment 6335 [details]
configuration
Comment 7 Dieter Ferdinand 2011-03-21 08:01:31 UTC
hello,
at the moment, i can only test it with win xp.

i set env-variables:
LC_ALL=de_DE
LANG=de-DE.utf8

if you need more information, you must tell me, where i find them.

at the first time, i have this problem, i try all settings, which i can make with samba-configuration-tool swat, but i don't find a setting, which works.

goodby
Comment 8 Volker Lendecke 2011-03-21 08:06:08 UTC
"unix charset = utf8" does not help?

Volker