Bug 3492 - rsync: connection unexpectedly closed (24 bytes read so far)
rsync: connection unexpectedly closed (24 bytes read so far)
Status: RESOLVED WORKSFORME
Product: rsync
Classification: Unclassified
Component: core
2.6.7
Other HP-UX
: P3 normal
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-08 23:31 UTC by Lee, JuGyun
Modified: 2006-10-15 13:34 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lee, JuGyun 2006-02-08 23:31:33 UTC
I encounter with error when run the shell script.

----------- Error Message ----------
rsync: connection unexpectedly closed (24 bytes read so far)
rsync error: error in rsync protocol data stream (code 12) at io.c(342)
----------- Error Message ----------

----------- Shell Script ----------
#!/bin/ksh
echo "SMC1A====="
rsync --recursive --compress --delete --no-relative --include='*' rsync://KKURO/data_a/SMC1A/smlog/20060206/Ssmlog*.* /SAS/CNV_DATA/SMSS/GET_DATA/KKUROA/SMC1A
echo "SMC2A====="
rsync --recursive --compress --delete --no-relative --include='*' rsync://KKURO/data_a/SMC2A/smlog/20060206/Ssmlog*.* /SAS/CNV_DATA/SMSS/GET_DATA/KKUROA/SMC2A
----------- Shell Script ----------

When I run the file, first rsync is completely suscess
but second rsync encounter the error.

How can resolve it?
Comment 1 Wayne Davison 2006-02-10 19:43:14 UTC
The issues-and-debugging page has information on how to find out what the problem is on the remote end of the connection (since the error you cite just tells us that the connection to the remote side closed unexpectedly).

http://rsync.samba.org/issues.html
Comment 2 Wayne Davison 2006-10-15 13:34:44 UTC
Closing due to lack of response.  If you are still seeing the problem, feel free to add extra information and re-open the bug.