Bug 3490 - --without-ldap and --without-ads do not appear to work
--without-ldap and --without-ads do not appear to work
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.21b
SGI IRIX
: P3 minor
: none
Assigned To: James Peach
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-07 10:40 UTC by Jason Mader
Modified: 2006-04-11 18:32 UTC (History)
0 users

See Also:


Attachments
Don't do LDAP checks if LDAP support is disabled (3.02 KB, patch)
2006-04-10 19:53 UTC, James Peach (outdated mail address)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Mader 2006-02-07 10:40:06 UTC
Configure checks for LDAP support and Active Directory support, despite explict --without on the command line.

checking for LDAP support... no
checking for Active Directory and krb5 support... no
checking for ldap_initialize... no
configure: WARNING: Active Directory Support requires ldap_initialize
checking for ldap_domain2hostlist... no
configure: WARNING: Active Directory Support requires ldap_domain2hostlist
checking for ldap_add_result_entry... no
configure: WARNING: Active Directory Support requires ldap_add_result_entry
Comment 1 Jason Mader 2006-02-07 10:41:12 UTC
env CC=cc CFLAGS="-O" /bin/sh configure --with-utmp --with-quotas --with-acl-support \
    --without-ldap --without-ads --without-winbind --without-libsmbclient
Comment 2 Gerald (Jerry) Carter 2006-04-10 07:38:56 UTC
Works fine in the urrent code.  I cannot reproduce any failures.
Comment 3 Jason Mader 2006-04-10 10:23:57 UTC
On Irix, in Samba 3.0.22, I still get the warnings:

checking for LDAP support... no
checking for Active Directory and krb5 support... no
checking for ldap_initialize... no
configure: WARNING: Active Directory Support requires ldap_initialize
checking for ldap_domain2hostlist... no
configure: WARNING: Active Directory Support requires ldap_domain2hostlist
checking for ldap_add_result_entry... no
configure: WARNING: Active Directory Support requires ldap_add_result_entry
Comment 4 Gerald (Jerry) Carter 2006-04-10 13:18:51 UTC
James, Can you look at this one? I can't reproduce it.  Maybe 
something to do with IRIX headers?
Comment 5 James Peach (outdated mail address) 2006-04-10 19:47:52 UTC
(In reply to comment #4)
> James, Can you look at this one? I can't reproduce it.  Maybe 
> something to do with IRIX headers?

Nope, it's a generic problem. configure.in doesn't correctly
distinguish between "no" and "auto". Patch is on its way.
Comment 6 James Peach (outdated mail address) 2006-04-10 19:53:40 UTC
Created attachment 1852 [details]
Don't do LDAP checks if LDAP support is disabled

Jason, can you please try this patch?
Comment 7 Jason Mader 2006-04-10 20:33:32 UTC
--without-ldap --without-ads:

configure:31458: checking for LDAP support
configure:31472: result: no
configure:32066: checking for Active Directory and krb5 support
configure:32080: result: no

That looks right!

I also tried --with-ldap --without-ads, and the result was right also.
Comment 8 James Peach (outdated mail address) 2006-04-11 18:32:15 UTC
Fixed in r15046.