Bug 3486 - Large ext3 and all xfs file sytems, permission denied
Large ext3 and all xfs file sytems, permission denied
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.21b
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-05 09:43 UTC by Hibbard T. Smith, JR
Modified: 2006-04-10 07:26 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hibbard T. Smith, JR 2006-02-05 09:43:37 UTC
I'm a relative newcomer to Samba, but very experienced with computers and linux.  I'm attempting to build a file/backup server for a small shop.  I'm using Fedora core 4 and samba on a system with a 2.1 TB RAID 50 array formatted as 1 very large xfs partition.  I want to share directories
(folders) within the partition with a few Windows XP-Pro SP2 systems which are our primary work-stations.  Currently I'm running samba-3.0.21b.  I started with the 3.0.14 that was released with FC4, but upgraded to the "latest and greatest" when I couldn't make the original work correctly. The kernel has also been upgraded to the Fedora released 2.6.14.1-1656-FC4-SMP.

Our business is primarily imaging and video.  A large percentage of our files are over 2 GB with some way over that.  Therefore, the only way this could be useful is with very large shared file systems.

Here are the issues:

When I try to share this large partition (2.1 TB xfs) and use smbclient to access it, the log (systemname.log) records an error which states that "the share doesn't exist or can't be accessed The error was access denied". I've made the share mode 0777 just to make sure permissions wouldn't get in the way.  If I move the share to an ext3 file system that's smaller than 2 GB it works correctly.  Any file system over 2 GB or any size xfs file system produces the error.  I haven't even tried to access the shares from a Windows system yet, I'm just using smbclient on the Fedora system.  I'm pretty sure I've got the config and permissions right because just changing the share to an
ext3 file system under 2 GB works fine.  

I haven't been able to find limits documented anywhere.  However, I see a great deal of discussion on the web about files over 2 GB along with suggestions that they work fine.  This would imply that file systems of over
2 GB must work okay.  I've also seen much discussion which would suggest that xfs works fine also.  All this discussion seems to indicate that I've got something wrong.  I'm just not sure what it is or how to proceed.  I have turned samba debugging up and the logs show that the correct user/group is being used and that case is working okay.
Comment 1 Gerald (Jerry) Carter 2006-04-10 07:26:43 UTC
Cannot reproduce this.  Please attach more deails (level 10 sbmd 
log, network trace, output from 'smbd -b' etc...) if this is still 
an issue for you.