Bug 3483 - RPM spec file has bad "Obsoletes" section
RPM spec file has bad "Obsoletes" section
Product: Samba 3.0
Classification: Unclassified
Component: Packaging
All All
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2006-02-04 09:16 UTC by Josh Kelley
Modified: 2006-02-04 11:33 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Josh Kelley 2006-02-04 09:16:29 UTC
The RPM spec file says that the samba package obsoletes samba-common, samba-client, and samba-swat.  This is incorrect and is left over from the all-in-one Samba RPM; it means that upgrading to the latest Samba RPM removes samba-client and samba-swat.
Comment 1 Gerald (Jerry) Carter 2006-02-04 11:33:32 UTC
This was a cut-n-paste error.  I've already fixed this in 
some pending patches and will be building new Fedora RPMS 
on Monday.  Thanks for reporting it though.