Bug 3471 - samba default charsets should follow locale
samba default charsets should follow locale
Status: RESOLVED DUPLICATE of bug 4240
Product: Samba 3.0
Classification: Unclassified
Component: Config Files
3.0.21a
x86 All
: P3 enhancement
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-31 14:50 UTC by Samuel Thibault
Modified: 2006-11-21 09:54 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Thibault 2006-01-31 14:50:22 UTC
Hi,

Currently, one has to manually set display charset and unix charset in
smb.conf for getting non-ascii letters working.

I don't understand why display charset currently defaults to ASCII
and unix charset defaults to UTF8.  Can't they just both default to
the current locale ? (particularly display charset). This would make
accented letters work in probably every usual case, and possibly fix some
of the charset bugs that were reported against samba in debian's bts.

Note that smbmount should pass to the kernel the current locale charset too.
That would possibly make people working on the same machine but with
different charsets be happy too.

Regards,
Samuel
Comment 1 TAKAHASHI Motonobu 2006-11-20 10:15:18 UTC
Currently the default value for "display charset" is "LOCALE", not "ASCII".
The description for "display charset" does not follow the current implementation.
Comment 2 Björn Jacke 2006-11-21 09:23:09 UTC
the display charset doc is fixed in svn and probably in next release, too. unix charset must be fixed and should not change randomly depending on locale settings.

*** This bug has been marked as a duplicate of 4240 ***
Comment 3 Samuel Thibault 2006-11-21 09:54:03 UTC
Is this because that's the server which uses unix charset, while clients always use display charset?