Bug 3470 - Small mistake in manual page mount.cifs (password->pass)
Small mistake in manual page mount.cifs (password->pass)
Status: RESOLVED FIXED
Product: CifsVFS
Classification: Unclassified
Component: user space tools
2.4
x86 Linux
: P3 normal
: ---
Assigned To: Steve French
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-31 08:49 UTC by Riccardo Escher
Modified: 2006-01-31 09:52 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Riccardo Escher 2006-01-31 08:49:57 UTC
mount.cifs version: 1.9-SUSE
autor of manual page mount.cifs(8): Steve French

In the manual page for mount.cifs the option for password is described as
"password=arg", but it should be "pass=arg".
Comment 1 Steve French 2006-01-31 09:06:33 UTC
Either form pass or password should work.

I retained the longer form "password" for those users who were familiar with smbfs, but allowed it to be shortened (shortest legal form is four characters long "pass") to ease typing (Linux users often prefer concise options that save typing once they understand).

I don't know which (the short form "pass" or the long form "password") is better to document - but had assumed that "password" was easier to remember.  Do you see a precedent in other man pages for how they deal with aliased options, options for which a short and a long form are accepted?  Presumably I could just note the short form of the longer option name in the description text for each.

Note that the current form of the man page is mirrored to the samba docs page:
e.g. http://us2.samba.org/samba/docs/man/manpages-3/mount.cifs.8.html
Comment 2 Riccardo Escher 2006-01-31 09:52:40 UTC
Ok, you are right. I tested it out and it's as you said. 

It was that I had problems (no access rights to the mount point) and at a certain point I noticed that the online help of mount.cifs told to use pass and the man page password. When you are investigating a problem you grab at every slight inconsistency you stumble on.

You might append the short form the next line under the long form:

password=arg
pass=arg
     specifies....

Solution:
I discovered finally the problem I had. I used a credential file with the content
user = myname
password = secret
(leading spaces!).

History:
This credential file worked together with smbfs for a long time till December 2005 (??). I noticed yesterday (January 30) that all my smbfs-shares were mounted, but invisible and unusable.
So I began to investigate, discovered the existence of cifs and implemented it.
Now it works.

Thaks a lot!