Bug 347 - Can not copy files from samba3 to WinXP-SP1
Can not copy files from samba3 to WinXP-SP1
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.0preX
All Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-25 13:18 UTC by John H Terpstra
Modified: 2005-11-14 09:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John H Terpstra 2003-08-25 13:18:13 UTC
One of my WinXP clients (a domain member) is having difficulties with current
CVS code (Sunday Aug 24).

I have extracted the OpenOffice 1.1rc3 WinInstall code on a samba share.
Any attempt to execute:
   setup -n
fails after 5 minutes with an error that the network connection was broken.

After this, WinXP is very unhappy and needs to be rebooted.

On the SuSE 8.2 samba server I noticed that there were 20 connections from the
one XP client to IPC$. During the period of inactivity (waiting to time out)
smbd was sitting idle.

No error conditions were reported to the log file.

I then tried to copy the ZIP file containing the original OO-1.1rc3 installer
and it failed with the same message.This time there were 12 conections to the
IPC$ share. Hmmm! This is does not make sense.


Additionally, I tried to open a PDF file from my home directory on the Samba3
server and experienced the same problem. Application is Acrobat v6.0.

I replaced the etherswitch, no change. All TCP/IP behaviour looks normal. Web
access and FTP access are normal.

Reverting to Samba-2.2.8a solves the problem instantly. Me thinks there are a bug!

I will try to produce log files and captures later, but JRA told me to put this
in buzilla so it is not lost. More to follow...
Comment 1 Gerald (Jerry) Carter 2003-10-01 10:35:21 UTC
pleas retest using 3.0.0 and report back.
Comment 2 John H Terpstra 2003-10-19 16:30:01 UTC
This is fixed.
Comment 3 Gerald (Jerry) Carter 2005-02-07 09:04:43 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 4 Gerald (Jerry) Carter 2005-08-24 10:15:22 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 5 Gerald (Jerry) Carter 2005-11-14 09:24:03 UTC
database cleanup