Bug 3466 - ImportError exception raises when trying to import samba.smb
ImportError exception raises when trying to import samba.smb
Status: RESOLVED DUPLICATE of bug 3567
Product: Samba 3.0
Classification: Unclassified
Component: python
All All
: P3 major
: none
Assigned To: Tim Potter
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2006-01-30 16:12 UTC by Peter Eisentraut
Modified: 2006-04-27 14:00 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Peter Eisentraut 2006-01-30 16:12:47 UTC
>>> import samba.smb
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  ImportError: /usr/lib/python2.3/site-packages/samba/smb.so: undefined symbol:

$ nm -D /usr/lib/python2.3/site-packages/samba/smb.so | grep cli_nt_session_open
         U cli_nt_session_open

As near as I can tell, this symbol was removed from source/rpc_client/cli_pipe.c in SVN revision 10783, which was between 3.0.20 and 3.0.21, without telling all the rest of the code about it.  The Python module is currently useless in that state; and there are a couple of other references to that function that should be checked.
Comment 1 Deryck Hodge 2006-04-27 14:00:00 UTC
Bug #3567 is the same as this and has a patch attached.
Will apply the patch (in some form) today.

*** This bug has been marked as a duplicate of 3567 ***