Bug 3454 - On SLES9/SP3 (samba3.0.20b-3.4-SUSE), umount of share kills smbd
On SLES9/SP3 (samba3.0.20b-3.4-SUSE), umount of share kills smbd
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.20b
x86 Linux
: P3 major
: none
Assigned To: Lars Müller
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-26 14:35 UTC by dwatson
Modified: 2006-02-01 19:14 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dwatson 2006-01-26 14:35:40 UTC
1. Use this smb.conf (note that modify_samba_config.pl resides on /root for testing purposes):
==========================start of smb.conf===============================
# Generated by /root/modify_samba_config.pl
#
[global]
	logonhome                 = \\%L\%U\.9xprofile
	adminusers                = Administrator, root
	addgroupscript            = /usr/sbin/groupadd -p "%g"
	addsharecommand           = /root/modify_samba_config.pl
	include                   = /etc/samba/dhcp.conf
	deletesharecommand        = /root/modify_samba_config.pl
	deleteuserfromgroupscript = /usr/sbin/groupmod -x "%u" "%g"
	adduserscript             = /usr/sbin/useradd -m "%u"
	maptoguest                = Bad User
	deleteprintercommand      = /root/modify_samba_config.pl
	addmachinescript          = /usr/sbin/useradd "%u"
	setprimarygroupscript     = /usr/sbin/usermod -g "%g" "%u"
	addprintercommand         = /root/modify_samba_config.pl
	printcapname              = cups
	deleteuserscript          = /usr/sbin/userdel -r "%u"
	domainlogons              = yes
	passdbbackend             = tdbsam
	cupsoptions               = raw
	printing                  = cups
	logondrive                = P:
	addusertogroupscript      = /usr/sbin/groupmod -m "%u" "%g"
	logonpath                 = \\%L\profiles\.msprofile
	workgroup                 = SAMBA_TEST
	printcapcachetime         = 750
	security                  = user#

	domainmaster              = yes

## Section - [shareD]
[shareD]
	read list                 = @root/@users
	write list                = user1
	path                      = /home/shareD

## Section - [homes]
[homes]
	readonly                  = No
	comment                   = Home Directories
	browseable                = No
	inheritacls               = Yes
	validusers                = %S

## Section - [users]
[users]
	readonly                  = No
	comment                   = All users
	path                      = /home
	inheritacls               = Yes
	vetofiles                 = /aquota.user/groups/shares/

## Section - [printers]
[printers]
	createmask                = 0600
	comment                   = All Printers
	browseable                = No
	printable                 = Yes
	path                      = /var/tmp

## Section - [shareC]
[shareC]
	readlist                  = @root,@users
	path                      = /home/shareC
	writelist                 = user1,user2

## Section - [print$]
[print$]
	createmask                = 0664
	directorymask             = 0775
	comment                   = Printer Drivers
	path                      = /var/lib/samba/drivers
	forcegroup                = ntadmin
	writelist                 = @ntadmin root

## Section - [shareA]
[shareA]
	readlist                  = user1
	path                      = /home/shareA
	writelist                 = user1

## Section - [groups]
[groups]
	readonly                  = No
	comment                   = All groups
	path                      = /home/groups
	inheritacls               = Yes

## Section - [profiles]
[profiles]
	readonly                  = No
	createmask                = 0600
	directorymask             = 0700
	comment                   = Network Profiles Service
	storedosattributes        = Yes
	path                      = %H

## Section - [shareB]
[shareB]
	readonly                  = yes
	path                      = /home/shareB

#
# end of generated smb.conf
#

## [pshareA]
[pshareA]
	printer		= filepr
	directorymask	= 0775
	createmask	= 0664
	comment		= filepr
	printable	= Yes
	path		= /var/spool/samba
	writelist	= @ntadmin root

## [pshareB]
[pshareB]
	printer		= filepr
	directorymask	= 0775
	createmask	= 0664
	comment		= filepr
	printable	= Yes
	path		= /var/spool/samba
	writelist	= @ntadmin root
======================end of smb.conf==================
2. Add root password with smbpasswd
3. Create the files for the shares:
        /home/shareA
        /home/shareB
        /home/shareC
        /home/shareD
4. Create user1 and user2 (be sure to add with smbpasswd--passwords are passwd1 and passwd2
5. Start samba with /etc/init.d/smb start
6. On a client machine, run "mkdir /tmp/testmount"
7. On the client machine, run "mount -t cifs //<server ip address>/shareA /tmp/testmount -o username=user1"; enter user1's password (passwd1) when prompted
8. umount /tmp/testmount--this kills smbd on the server.  It leaves behind /var/run/samba/smbd.pid and leaves no messages in log.smbd or /var/log/messages.

A rebuild/reinstall of samba from the SLES9/SP3 samba source solves this problem if using tdbsam for the backend; the rebuild does not contain the ldapsam builtin by default (probably because ldap.h cannot be found by configure).
Comment 1 Gerald (Jerry) Carter 2006-01-31 11:52:11 UTC
Lars, could you follow up on this one?  Thanks.
Comment 2 Lars Müller 2006-01-31 14:58:13 UTC
This is a x86, x86_64, ppc(64), or s390(x) system?
Comment 3 dwatson 2006-01-31 15:39:19 UTC
x86.
Comment 4 dwatson 2006-02-01 16:23:16 UTC
I can no longer reproduce this problem.  Can we resolve it as INVALID and re-open it later if I can reproduce it?
Comment 5 Lars Müller 2006-02-01 19:14:08 UTC
Sure.  And thanks for the feedback!