Bug 3445 - Python Modules Compilation Errors
Python Modules Compilation Errors
Status: RESOLVED WORKSFORME
Product: Samba 4.0
Classification: Unclassified
Component: Other
unspecified
x64 Linux
: P3 normal
: ---
Assigned To: Tim Potter
Andrew Bartlett
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-25 07:59 UTC by Devilopers
Modified: 2006-04-23 10:16 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Devilopers 2006-01-25 07:59:19 UTC
I'have try to compile python swig modules but I have encountered the following problem:

$ make idl_full swig

Rebuilding all idl files in librpc/idl
Compiling librpc/idl/atsvc.idl
Compiling librpc/idl/audiosrv.idl
Compiling librpc/idl/browser.idl
Compiling librpc/idl/dbgidl.idl
Compiling librpc/idl/dcerpc.idl

<CUT>

Compiling scripting/swig/dcerpc_wrap.c
In file included from ./include/includes.h:25,
                 from scripting/swig/dcerpc_wrap.c:1510:
./include/config.h:1085:1: warning: "_GNU_SOURCE" redefined
In file included from /usr/include/python2.4/Python.h:8,
                 from scripting/swig/dcerpc_wrap.c:22:
/usr/include/python2.4/pyconfig.h:823:1: warning: this is the location of the previous definition
scripting/swig/dcerpc_wrap.c: In function `new_samr_String_array':
scripting/swig/dcerpc_wrap.c:1880: error: invalid application of `sizeof' to incomplete type `samr_String'
scripting/swig/dcerpc_wrap.c: At top level:
scripting/swig/dcerpc_wrap.c:1887: error: return type is an incomplete type
scripting/swig/dcerpc_wrap.c: In function `samr_String_array_getitem':
scripting/swig/dcerpc_wrap.c:1888: error: invalid use of undefined type `struct samr_String'
scripting/swig/dcerpc_wrap.c:1888: error: dereferencing pointer to incomplete type
scripting/swig/dcerpc_wrap.c:1888: warning: `return' with a value, in function returning void
scripting/swig/dcerpc_wrap.c: At top level:
scripting/swig/dcerpc_wrap.c:1890: error: parameter `value' has incomplete type
scripting/swig/dcerpc_wrap.c: In function `samr_String_array_setitem':
scripting/swig/dcerpc_wrap.c:1891: error: invalid use of undefined type `struct samr_String'
scripting/swig/dcerpc_wrap.c:1891: error: dereferencing pointer to incomplete type
scripting/swig/dcerpc_wrap.c: In function `new_samr_RidType_array':
scripting/swig/dcerpc_wrap.c:1928: error: invalid application of `sizeof' to incomplete type `samr_RidType'
scripting/swig/dcerpc_wrap.c: At top level:
scripting/swig/dcerpc_wrap.c:1935: error: return type is an incomplete type
scripting/swig/dcerpc_wrap.c: In function `samr_RidType_array_getitem':
scripting/swig/dcerpc_wrap.c:1936: error: invalid use of undefined type `struct samr_RidType'
scripting/swig/dcerpc_wrap.c:1936: error: dereferencing pointer to incomplete type
scripting/swig/dcerpc_wrap.c:1936: warning: `return' with a value, in function returning void
scripting/swig/dcerpc_wrap.c: At top level:
scripting/swig/dcerpc_wrap.c:1938: error: parameter `value' has incomplete type
scripting/swig/dcerpc_wrap.c: In function `samr_RidType_array_setitem':
scripting/swig/dcerpc_wrap.c:1939: error: invalid use of undefined type `struct samr_RidType'
scripting/swig/dcerpc_wrap.c:1939: error: dereferencing pointer to incomplete type
scripting/swig/dcerpc_wrap.c: In function `_wrap_pipe_connect':
scripting/swig/dcerpc_wrap.c:2042: warning: passing arg 4 of `dcerpc_pipe_connect' from incompatible pointer type
scripting/swig/dcerpc_wrap.c:2042: warning: passing arg 5 of `dcerpc_pipe_connect' makes pointer from integer without a cast
scripting/swig/dcerpc_wrap.c:2042: warning: passing arg 6 of `dcerpc_pipe_connect' from incompatible pointer type
scripting/swig/dcerpc_wrap.c: In function `_wrap_samr_String_array_getitem':
scripting/swig/dcerpc_wrap.c:2445: error: storage size of 'result' isn't known
scripting/swig/dcerpc_wrap.c:2460: error: invalid application of `sizeof' to incomplete type `samr_String'
scripting/swig/dcerpc_wrap.c:2461: error: invalid application of `sizeof' to incomplete type `samr_String'
scripting/swig/dcerpc_wrap.c: In function `_wrap_samr_String_array_setitem':
scripting/swig/dcerpc_wrap.c:2474: error: storage size of 'arg3' isn't known
scripting/swig/dcerpc_wrap.c:2494: error: dereferencing pointer to incomplete type
scripting/swig/dcerpc_wrap.c: In function `_wrap_samr_RidType_array_getitem':
scripting/swig/dcerpc_wrap.c:2748: error: storage size of 'result' isn't known
scripting/swig/dcerpc_wrap.c:2763: error: invalid application of `sizeof' to incomplete type `samr_RidType'
scripting/swig/dcerpc_wrap.c:2764: error: invalid application of `sizeof' to incomplete type `samr_RidType'
scripting/swig/dcerpc_wrap.c: In function `_wrap_samr_RidType_array_setitem':
scripting/swig/dcerpc_wrap.c:2777: error: storage size of 'arg3' isn't known
scripting/swig/dcerpc_wrap.c:2797: error: dereferencing pointer to incomplete type
scripting/swig/dcerpc_wrap.c: In function `init_dcerpc':
scripting/swig/dcerpc_wrap.c:8889: error: too many arguments to function `lp_load'
make: *** [scripting/swig/dcerpc_wrap.o] Error 1
Comment 1 Jelmer Vernooij 2006-03-10 07:36:08 UTC
Reassigning to tpot.
Comment 2 Jelmer Vernooij 2006-04-23 10:16:11 UTC
Can't reproduce in a recent revision. Looks like it was fixed recently.