Bug 3438 - rpcclient bug trying to add printer
rpcclient bug trying to add printer
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.21a
x86 Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-23 14:35 UTC by Manuel
Modified: 2006-04-08 07:56 UTC (History)
0 users

See Also:


Attachments
Errormessages from cupsaddsmb (10.82 KB, text/plain)
2006-03-16 04:15 UTC, Klaus Henske
no flags Details
Debuglevel 5 Output of rpcclient with the comman set driver (132.74 KB, text/plain)
2006-03-16 06:27 UTC, Klaus Henske
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel 2006-01-23 14:35:15 UTC
Running Debian Sarge, but compiled 3.0.21a from sources.
trying to add a printer driver, here is what I keep getting: 

rpcclient -U'root%xxxxx' -c 'adddriver "Windows NT x86" "Phaser01:\
tkph7401.dll:\
tkph7401.ppd:\
tekinst.dll:\
adobeps4.hlp:\
NULL:\
RAW:\
:adfonts.mfm,adobeps4.drv,adobeps4.hlp,apple380.spd,captport.dll,iconlib.dll,licagrmt.pdf,lpt.vxd,psmon.dll,readme.doc,tek95adb.inf,tekinst.dll,tkph7401.dll,tkph7401.ppd"' WINDA
Connecting to host=WINDA
resolve_lmhosts: Attempting lmhosts lookup for name WINDA<0x20>
resolve_wins: Attempting wins lookup for name WINDA<0x20>
resolve_wins: using WINS server 127.0.0.1 and tag '*'
Got a positive name query response from 127.0.0.1 ( 192.168.2.1 )
Connecting to 192.168.2.1 at port 445
Doing spnego session setup (blob length=16)
server didn't supply a full spnego negprot
Got challenge flags:
Got NTLMSSP neg_flags=0x608a0235
NTLMSSP: Set final flags:
Got NTLMSSP neg_flags=0x60080215
NTLMSSP Sign/Seal - Initialising with flags:
Got NTLMSSP neg_flags=0x60080215
rpc_pipe_bind: Remote machine WINDA pipe \lsarpc fnum 0x74a8 bind request returned ok.
lsa_io_sec_qos: length c does not match size 8
rpc_pipe_bind: Remote machine WINDA pipe \spoolss fnum 0x74a9 bind request returned ok.
result was WERR_BADFILE


This bug seems very similar, if not the same as reported by bug #3396
Comment 1 Klaus Henske 2006-03-16 04:15:41 UTC
Created attachment 1806 [details]
Errormessages from cupsaddsmb

This ist the output of a cupsaddsmb call. This is for the Versieon 3.0.14a and Version 3.0.21b too.

I hope, that samba goes not so far to windows, that samba take the bad site of windows too ;)
Comment 2 Klaus Henske 2006-03-16 06:27:51 UTC
Created attachment 1807 [details]
Debuglevel 5 Output of rpcclient with the comman set driver

This ist the Output from rpcclient of the version 3.0.14a and 3.0.21b

set driver command
Comment 3 Gerald (Jerry) Carter 2006-03-16 07:00:02 UTC
These are two different bugs.  The original bug is mostly caused by 
not copying the files to the correct location in [print$] on the
server before issueing the 'adddriver call'.

The second bug is an authorization issue.  Without a level 10 debug 
log from the server (not client), I can't give more information.
But it is very doubtful that this a source level bug.
Comment 4 Gerald (Jerry) Carter 2006-04-08 07:56:46 UTC
no response.  Closing.