Bug 3367 - Word cannot lead the storage procedure due to an authorization error to end
Word cannot lead the storage procedure due to an authorization error to end
Status: RESOLVED DUPLICATE of bug 3346
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.21
SGI IRIX
: P3 regression
: none
Assigned To: James Peach
Samba QA Contact
http://www.itp1.uni-stuttgart.de/samb...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-02 05:14 UTC by Steffen Bücheler
Modified: 2006-01-09 06:29 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen Bücheler 2006-01-02 05:14:32 UTC
Since the version 3.0.21 there is an error when storing a file to the home directory. In German the error message is: "Word kann den Speicherungsvorgang aufgrund eines Berechtigungsfehlers nicht zu Ende führen." Dies Bug is also in the new version 3.0.21a.
Comment 1 Lars Müller 2006-01-02 09:53:10 UTC
James: IRIX is yours. ;)
Comment 2 Lars Müller 2006-01-02 09:55:26 UTC
Steffen: This defect is only valid while working with word?  And this happens only when running Samba on IRIX?
Comment 3 James Peach (outdated mail address) 2006-01-02 15:29:01 UTC
(In reply to comment #2)
> Steffen: This defect is only valid while working with word?  And this happens
> only when running Samba on IRIX?

Please post the output of
    uname -Ra
    xfs_growfs -n <filesystem> (for the filesystem in question)
    smbd -b

I think we'll probably need a snoop trace to see what's going on in this one. The snoop command you should use is
    snoop -P -d <interface> -s 512 -o <output file>
Comment 4 Steffen Bücheler 2006-01-03 03:03:06 UTC
Here are some additional informations:

1) The problem occurs with Mozilla-Mail too (mails are stored in the Windows home directory, not in the local Windows user profile).

2) We run samba only on IRIX:

   uname -Ra: IRIX64 goliath 6.5 6.5.22f 10070055 IP27

   goliath 2# xfs_growfs -n /raid
   meta-data=/raid                  isize=256    agcount=285, agsize=1048576        blks
   data     =                       bsize=4096   blocks=298718720, imaxpct=25
            =                       sunit=0      swidth=0 blks, unwritten=1
   naming   =version 2              bsize=4096   mixed-case=Y
   log      =internal               bsize=4096   blocks=32768
   realtime =none                   extsz=65536  blocks=0, rtextents=0

./smbd -b:

Build environment:
   Built by:    root@goliath
   Built on:    Mon Jan  2 09:08:23 MET 2006
   Built using: gcc
   Build host:  IRIX64 goliath 6.5 10070055 IP27
   SRCDIR:      /scratch/samba-3.0.21a/source
   BUILDDIR:    /scratch/samba-3.0.21a/source

Paths:
   SBINDIR: /usr/local/samba/sbin
   BINDIR: /usr/local/samba/bin
   SWATDIR: /usr/local/samba/swat
   CONFIGFILE: /usr/local/samba/lib/smb.conf
   LOGFILEBASE: /usr/local/samba/var
   LMHOSTSFILE: /usr/local/samba/lib/lmhosts
   LIBDIR: /usr/local/samba/lib
   SHLIBEXT: so
   LOCKDIR: /usr/local/samba/var/locks
   PIDDIR: /usr/local/samba/var/locks
   SMB_PASSWD_FILE: /usr/local/samba/private/smbpasswd
   PRIVATE_DIR: /usr/local/samba/private

 System Headers:
   HAVE_SYS_ACL_H
   HAVE_SYS_ATTRIBUTES_H
   HAVE_SYS_CAPABILITY_H
   HAVE_SYS_CDEFS_H
   HAVE_SYS_FCNTL_H
   HAVE_SYS_FILIO_H
   HAVE_SYS_IOCTL_H
   HAVE_SYS_IPC_H
   HAVE_SYS_MMAN_H
   HAVE_SYS_MODE_H
   HAVE_SYS_MOUNT_H
   HAVE_SYS_PARAM_H
   HAVE_SYS_PRCTL_H
   HAVE_SYS_QUOTA_H
   HAVE_SYS_RESOURCE_H
   HAVE_SYS_SELECT_H
   HAVE_SYS_SHM_H
   HAVE_SYS_SOCKET_H
   HAVE_SYS_SOCKIO_H
   HAVE_SYS_STATFS_H
   HAVE_SYS_STATVFS_H
   HAVE_SYS_STAT_H
   HAVE_SYS_SYSCALL_H
   HAVE_SYS_SYSLOG_H
   HAVE_SYS_SYSMACROS_H
   HAVE_SYS_TERMIO_H
   HAVE_SYS_TIME_H
   HAVE_SYS_TYPES_H
   HAVE_SYS_UIO_H
   HAVE_SYS_UNISTD_H
   HAVE_SYS_UN_H
   HAVE_SYS_VFS_H
   HAVE_SYS_WAIT_H

 Headers:
   HAVE_AIO_H
   HAVE_ALLOCA_H
   HAVE_ARPA_INET_H
   HAVE_CTYPE_H
   HAVE_DIRENT_H
   HAVE_DLFCN_H
   HAVE_FCNTL_H
   HAVE_GLOB_H
   HAVE_GRP_H
   HAVE_INTTYPES_H
   HAVE_LANGINFO_H
   HAVE_LASTLOG_H
   HAVE_LBER_H
   HAVE_LDAP_H
   HAVE_LIBEXC_H
   HAVE_LIMITS_H
   HAVE_LOCALE_H
   HAVE_MEMORY_H
   HAVE_MNTENT_H
   HAVE_NETINET_IN_SYSTM_H
   HAVE_NETINET_IP_H
   HAVE_NETINET_TCP_H
   HAVE_NET_IF_H
   HAVE_NS_API_H
   HAVE_POLL_H
   HAVE_READLINE_HISTORY_H
   HAVE_READLINE_READLINE_H
   HAVE_RPCSVC_YPCLNT_H
   HAVE_RPCSVC_YP_PROT_H
   HAVE_RPC_NETTYPE_H
   HAVE_RPC_RPC_H
   HAVE_SECURITY_PAM_APPL_H
   HAVE_SECURITY_PAM_MODULES_H
   HAVE_SECURITY__PAM_MACROS_H
   HAVE_SHADOW_H
   HAVE_STDARG_H
   HAVE_STDLIB_H
   HAVE_STRINGS_H
   HAVE_STRING_H
   HAVE_STROPTS_H
   HAVE_SYSLOG_H
   HAVE_TERMIOS_H
   HAVE_TERMIO_H
   HAVE_UNISTD_H
   HAVE_UTIME_H

 UTMP Options:
   HAVE_GETUTMPX
   HAVE_UTMPX_H
   HAVE_UTMP_H
   HAVE_UT_UT_EXIT
   HAVE_UT_UT_ID
   HAVE_UT_UT_NAME
   HAVE_UT_UT_PID
   HAVE_UT_UT_TIME
   HAVE_UT_UT_TYPE
   HAVE_UT_UT_USER
   PUTUTLINE_RETURNS_UTMP
   WITH_UTMP

 HAVE_* Defines:
   HAVE_ATEXIT
   HAVE_ATTR_GET
   HAVE_ATTR_GETF
   HAVE_ATTR_LIST
   HAVE_ATTR_LISTF
   HAVE_ATTR_REMOVE
   HAVE_ATTR_REMOVEF
   HAVE_ATTR_SET
   HAVE_ATTR_SETF
   HAVE_BER_SCANF
   HAVE_CHMOD
   HAVE_CHOWN
   HAVE_CHROOT
   HAVE_COMPILER_WILL_OPTIMIZE_OUT_FNS
   HAVE_CONNECT
   HAVE_CREAT64
   HAVE_CRYPT
   HAVE_CUPS
   HAVE_DIRENT_D_OFF
   HAVE_DLCLOSE
   HAVE_DLERROR
   HAVE_DLOPEN
   HAVE_DLSYM
   HAVE_DQB_FSOFTLIMIT
   HAVE_DUP2
   HAVE_ENDMNTENT
   HAVE_ENDNETGRENT
   HAVE_ERRNO_DECL
   HAVE_EXECL
   HAVE_EXPLICIT_LARGEFILE_SUPPORT
   HAVE_FCHMOD
   HAVE_FCHOWN
   HAVE_FCNTL_LOCK
   HAVE_FCVT
   HAVE_FCVTL
   HAVE_FOPEN64
   HAVE_FSEEK64
   HAVE_FSEEKO64
   HAVE_FSTAT
   HAVE_FSTAT64
   HAVE_FSYNC
   HAVE_FTELL64
   HAVE_FTELLO64
   HAVE_FTRUNCATE
   HAVE_FTRUNCATE64
   HAVE_FTRUNCATE_EXTEND
   HAVE_FUNCTION_MACRO
   HAVE_GETCWD
   HAVE_GETDENTS
   HAVE_GETGRENT
   HAVE_GETGRNAM
   HAVE_GETMNTENT
   HAVE_GETNETGRENT
   HAVE_GETRLIMIT
   HAVE_GETSPNAM
   HAVE_GETTIMEOFDAY_TZ
   HAVE_GLOB
   HAVE_GRANTPT
   HAVE_ICONV
   HAVE_IFACE_IFCONF
   HAVE_IMMEDIATE_STRUCTURES
   HAVE_INITGROUPS
   HAVE_INNETGR
   HAVE_IPRINT
   HAVE_IRIX_SPECIFIC_CAPABILITIES
   HAVE_KERNEL_OPLOCKS_IRIX
   HAVE_LDAP
   HAVE_LDAP_ADD_RESULT_ENTRY
   HAVE_LDAP_DOMAIN2HOSTLIST
   HAVE_LDAP_INIT
   HAVE_LDAP_INITIALIZE
   HAVE_LDAP_SET_REBIND_PROC
   HAVE_LIBEXC
   HAVE_LIBLBER
   HAVE_LIBLDAP
   HAVE_LIBPAM
   HAVE_LIBREADLINE
   HAVE_LINK
   HAVE_LONGLONG
   HAVE_LSEEK64
   HAVE_LSTAT64
   HAVE_MEMMOVE
   HAVE_MEMSET
   HAVE_MKNOD
   HAVE_MKTIME
   HAVE_MMAP
   HAVE_NANOSLEEP
   HAVE_NATIVE_ICONV
   HAVE_NEW_LIBREADLINE
   HAVE_NL_LANGINFO
   HAVE_NO_ACLS
   HAVE_NO_AIO
   HAVE_OPEN64
   HAVE_PASSWD_PW_AGE
   HAVE_PASSWD_PW_COMMENT
   HAVE_PATHCONF
   HAVE_PIPE
   HAVE_POLL
   HAVE_PRCTL
   HAVE_PREAD
   HAVE_PREAD64
   HAVE_PUTUTLINE
   HAVE_PUTUTXLINE
   HAVE_PWRITE
   HAVE_PWRITE64
   HAVE_QUOTACTL_4A
   HAVE_RAND
   HAVE_RANDOM
   HAVE_READDIR64
   HAVE_READLINK
   HAVE_REALPATH
   HAVE_RENAME
   HAVE_ROOT
   HAVE_SECURE_MKSTEMP
   HAVE_SEEKDIR64
   HAVE_SELECT
   HAVE_SETBUFFER
   HAVE_SETGROUPS
   HAVE_SETLINEBUF
   HAVE_SETLOCALE
   HAVE_SETMNTENT
   HAVE_SETNETGRENT
   HAVE_SETPGID
   HAVE_SETSID
   HAVE_SHMGET
   HAVE_SHM_OPEN
   HAVE_SIGACTION
   HAVE_SIGBLOCK
   HAVE_SIGPROCMASK
   HAVE_SIGSET
   HAVE_SIG_ATOMIC_T_TYPE
   HAVE_SNPRINTF
   HAVE_SNPRINTF_DECL
   HAVE_SOCKLEN_T_TYPE
   HAVE_SRAND
   HAVE_SRANDOM
   HAVE_STAT64
   HAVE_STAT_HIRES_TIMESTAMPS
   HAVE_STAT_ST_ATIM
   HAVE_STAT_ST_BLKSIZE
   HAVE_STAT_ST_BLOCKS
   HAVE_STAT_ST_CTIM
   HAVE_STAT_ST_MTIM
   HAVE_STRCASECMP
   HAVE_STRCHR
   HAVE_STRDUP
   HAVE_STRERROR
   HAVE_STRFTIME
   HAVE_STRLCAT
   HAVE_STRLCPY
   HAVE_STRPBRK
   HAVE_STRTOUL
   HAVE_STRUCT_DIRENT64
   HAVE_STRUCT_FLOCK64
   HAVE_STRUCT_STAT_ST_RDEV
   HAVE_STRUCT_TIMESPEC
   HAVE_ST_RDEV
   HAVE_SYMLINK
   HAVE_SYSCALL
   HAVE_SYSCONF
   HAVE_SYSLOG
   HAVE_TELLDIR64
   HAVE_UNIXSOCKET
   HAVE_UNSIGNED_CHAR
   HAVE_UPDWTMP
   HAVE_UPDWTMPX
   HAVE_USLEEP
   HAVE_UTIMBUF
   HAVE_UTIME
   HAVE_UTIMES
   HAVE_UX_UT_SYSLEN
   HAVE_VA_COPY
   HAVE_VOLATILE
   HAVE_VSNPRINTF
   HAVE_VSNPRINTF_DECL
   HAVE_VSYSLOG
   HAVE_WAITPID
   HAVE_YP_GET_DEFAULT_DOMAIN
   HAVE__CHDIR
   HAVE__CLOSE
   HAVE__CLOSEDIR
   HAVE__DUP
   HAVE__DUP2
   HAVE__FCHDIR
   HAVE__FCNTL
   HAVE__FORK
   HAVE__FSTAT
   HAVE__FSTAT64
   HAVE__GETCWD
   HAVE__GETDENTS
   HAVE__LSEEK
   HAVE__LSTAT
   HAVE__LSTAT64
   HAVE__OPEN
   HAVE__OPEN64
   HAVE__OPENDIR
   HAVE__PREAD
   HAVE__PREAD64
   HAVE__PWRITE
   HAVE__PWRITE64
   HAVE__READ
   HAVE__READDIR
   HAVE__READDIR64
   HAVE__SEEKDIR
   HAVE__STAT
   HAVE__STAT64
   HAVE__TELLDIR
   HAVE__WRITE
   HAVE___CLOSE
   HAVE___FORK
   HAVE___GETCWD
   HAVE___WRITE

 --with Options:
   WITH_UTMP
   WITH_WINBIND

 Build Options:
   COMPILER_SUPPORTS_LL
   DEFAULT_DISPLAY_CHARSET
   DEFAULT_DOS_CHARSET
   DEFAULT_UNIX_CHARSET
   IRIX
   IRIX6
   LDAP_SET_REBIND_PROC_ARGS
   PACKAGE_BUGREPORT
   PACKAGE_NAME
   PACKAGE_STRING
   PACKAGE_TARNAME
   PACKAGE_VERSION
   REPLACE_GETPASS
   RETSIGTYPE
   SIZEOF_INO_T
   SIZEOF_INT
   SIZEOF_LONG
   SIZEOF_OFF_T
   SIZEOF_SHORT
   STAT_STATVFS64
   STAT_ST_BLOCKSIZE
   STDC_HEADERS
   STRING_STATIC_MODULES
   SYSCONF_SC_NGROUPS_MAX
   SYSCONF_SC_NPROC_ONLN
   SYSV
   TIME_WITH_SYS_TIME
   USE_SETREUID
   WITH_WINBIND
   WORDS_BIGENDIAN
   auth_script_init
   charset_CP437_init
   charset_CP850_init
   loff_t
   offset_t
   static_init_auth
   static_init_charset
   static_init_idmap
   static_init_pdb
   static_init_rpc
   static_init_vfs
   vfs_audit_init
   vfs_cap_init
   vfs_default_quota_init
   vfs_expand_msdfs_init
   vfs_extd_audit_init
   vfs_fake_perms_init
   vfs_full_audit_init
   vfs_netatalk_init
   vfs_readonly_init
   vfs_recycle_init
   vfs_shadow_copy_init

Type sizes:
   sizeof(char):    1
   sizeof(int):     4
   sizeof(long):    4
   sizeof(uint8):   1
   sizeof(uint16):  2
   sizeof(uint32):  4
   sizeof(short):   2
   sizeof(void*):   4

Builtin modules:
    pdb_ldap pdb_smbpasswd pdb_tdbsam pdb_guest rpc_lsa rpc_reg rpc_lsa_ds rpc_w ks rpc_svcctl rpc_ntsvcs rpc_net rpc_dfs rpc_srv rpc_spoolss rpc_eventlog rpc_sa mr idmap_ldap idmap_tdb auth_rhosts auth_sam auth_unix auth_winbind auth_server auth_domain auth_builtin

Hope that this helps.
Comment 5 James Peach (outdated mail address) 2006-01-04 18:04:00 UTC
(In reply to comment #4)
> Here are some additional informations:

Can you please also post smbd -V and smb.conf?

> Hope that this helps.

Not as much as I'd hoped. I think I'll need a snoop trace to get further with this one. If the snoop instructions above are unclear, email me jpeach@sgi.com and I'll walk you through it. You'll need to capture the connection setup as well as the error itself. The simplest way to reset the connection is to restart smbd.
Comment 6 Rudy Gevaert 2006-01-09 02:23:09 UTC
I have the same problem on solaris 8 with 3.0.21 and 3.0.21a.  I had to downgrade to 3.0.20 to let my users work again.

I'm now compiling the latest samba on solaris 10 to see if I can reproduce the problem.  I'm willing to help by giving more information once this is set up.
Comment 7 Rudy Gevaert 2006-01-09 04:20:49 UTC
I set up a solaris 10 and got the same problem

I then recompiled (by adding the -g option to the CFLAGS in the Makefile).  
I added the panic line in my smb.conf, ran gdb and attached to the pid of smbd of my user.  Running the backtrace gives:

(gdb) bt
#0  0xff13d8e0 in _waitid () from /lib/libc.so.1
#1  0xff0e5bf0 in _waitpid () from /lib/libc.so.1
#2  0xff130b6c in waitpid () from /lib/libc.so.1
#3  0xff12492c in system () from /lib/libc.so.1
#4  0x001c786c in smb_panic2 ()
#5  0x001c77d8 in smb_panic ()
#6  0x001b41b0 in fault_report ()
#7  0x001b4214 in sig_fault ()
#8  0xff13c534 in __sighndlr () from /lib/libc.so.1
#9  0xff1319a0 in call_user_handler () from /lib/libc.so.1
#10 0x001f47f8 in process_oplock_break_message ()
#11 0x001d1c38 in message_dispatch ()
#12 0x000a4258 in receive_message_or_smb ()
#13 0x000a5fa4 in smbd_process ()
#14 0x002432f4 in main ()
Comment 8 Steffen Bücheler 2006-01-09 05:35:19 UTC
(In reply to comment #5)
> Can you please also post smbd -V and smb.conf?
> 
goliath 7# ./smbd -V
Version 3.0.21a

goliath 10# more smb.conf
[global]
        unix charset = ISO-8859-1
        workgroup = ITP1
        server string = PDC [Samba %v]
        passwd program = /usr/bin/yppasswd
        username map = /usr/local/samba/usermap.txt
        log level = 3
        time server = Yes
        logon script = itp1.bat
        logon drive = U:
        domain logons = Yes
        os level = 64
        preferred master = Yes
        domain master = Yes
        dns proxy = No
        ldap ssl = no
        username = +xxxx,+yyyy
        hosts allow = 129.69.45., 127.0.0.1
        locking = No

[netlogon]
        comment = The domain logon service
        path = /usr/local/samba/logon
        browseable = No
        csc policy = disable

[homes]
        comment = Home Directory
        read only = No
        browseable = No
        csc policy = disable
Comment 9 Gerald (Jerry) Carter 2006-01-09 06:29:04 UTC
The backtrace shows this to be the same as the alighment bug 
I'm working on Solaris.

*** This bug has been marked as a duplicate of 3346 ***