Bug 3360 - Configure test for pam_start fails on Solaris 10, Studio 11
Configure test for pam_start fails on Solaris 10, Studio 11
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.9
Sparc Solaris
: P3 normal
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-29 13:44 UTC by David S. Collier-Brown
Modified: 2005-12-30 21:19 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David S. Collier-Brown 2005-12-29 13:44:48 UTC
configure reports
---
froggy> ./configure 2>&1 | tee oops.log
checking build system type... sparc-sun-solaris2.10
checking host system type... sparc-sun-solaris2.10
SAMBA VERSION: 3.9.0-SVN-build-12484
BUILD REVISION: 12484
...

checking for pam_start in -lpam... no
checking configure summary... configure: error: summary failure. Aborting config
---

This is in testing the code
---
+ eval echo 'configure:27882: "$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5"'
--
where the conftest file conains
---
cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h.  */

/* Override any gcc2 internal prototype to avoid an error.  */
#ifdef __cplusplus
extern "C"
#endif
/* We use char because int might match the return type of a gcc2
   builtin and then its argument prototype would still apply.  */
char pam_start ();
int
main ()
{
pam_start ();
  ;
  return 0;
}
_ACEOF
Comment 1 David S. Collier-Brown 2005-12-29 13:51:23 UTC
Adding set -x just before 
echo "$as_me:$LINENO: checking for pam_start in -lpam" >&5
gave me, for both samba 3.0 and 4.0, the follow\ing
---
checking for setjmp.h... yes
checking for security/pam_appl.h... (cached) yes
+ echo 'configure:27854: checking for pam_start in -lpam'
+ echo -n 'checking for pam_start in -lpam... '
checking for pam_start in -lpam... + test '' = set
+ cat
+ cat confdefs.h
+ cat
+ rm -f conftest.o conftest
+ eval echo 'configure:27882: "$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5"'
++ echo configure:27882: 'gcc -o conftest  -Iheimdal_build -Iheimdal/lib/krb5 -Iheimdal/lib/gssapi -Iheimdal/lib/asn1 -Iheimdal/lib/com_err -Iheimdal/lib/hdb -Iheimdal/kdc -Iheimdal/lib/roken -Iheimdal/lib/des -DORBIT2=1 -mt -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/openwin/include -I/usr/sfw/include -I/usr/sfw/include/freetype2     conftest.c -lpam   -lsocket -lnsl  >&5'
+ ac_status=1
+ grep -v '^ *+' conftest.er1
+ rm -f conftest.er1
+ cat conftest.err
+ echo 'configure:27888: $? = 1'
+ exit 1
+ echo 'configure: failed program was:'
+ sed 's/^/| /' conftest.c
+ ac_cv_lib_ext_pam_pam_start=no
+ ac_cv_lib_ext_pam=no
+ rm -f conftest.err conftest.o conftest conftest.c
+ echo 'configure:27916: result: no'
+ echo no
no
+ test no = yes
+ LIBS='-lsocket -lnsl '
+ test no = yes
+ test xyes = xyes -a xno = xyes
+ SMB_INFO_EXT_LIBS='
###################################
# Start Ext Lib CRYPT
Comment 2 David S. Collier-Brown 2005-12-30 21:19:59 UTC
I can't recreate this, even by cleaning 
back to bare metal. I'm closing it as an
unreproducable/fixed problem.

--dave