Bug 3300 - CUPS connection errors on new start of SMBD
CUPS connection errors on new start of SMBD
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.20b
x86 Linux
: P3 minor
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-05 14:47 UTC by Andrei Nazarenko
Modified: 2005-12-20 07:17 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Nazarenko 2005-12-05 14:47:27 UTC
I have no printing/cups enabled on my server and I do not want to use printing features of Samba - there is no [printers] section in my smb.conf.

I have not found a way to disable printing in smb.conf, so every time smbd is started it tries to connect to the cups daemon (twice) with the following error messages:

[2005/12/05 05:00:05, 0] smbd/server.c:main(806)
  smbd version 3.0.20b-3.2-SUSE started.
  Copyright Andrew Tridgell and the Samba Team 1992-2005
[2005/12/05 05:00:05, 0] printing/print_cups.c:cups_cache_reload(85)
  Unable to connect to CUPS server localhost - Connection refused
[2005/12/05 05:00:05, 0] printing/print_cups.c:cups_cache_reload(85)
  Unable to connect to CUPS server localhost - Connection refused

Is this intended? Shouldn't printing be disabled when there is no [printers] section present in the config file?

I am sorry if I seems more like a question or a feature request rather than a bug report, but like I said I could not find a way to disable printing.
Comment 1 Andrei Nazarenko 2005-12-20 06:15:25 UTC
Just wondering if this can be fixed before 3.0.21 is released.
Comment 2 Gerald (Jerry) Carter 2005-12-20 06:52:16 UTC
The problem is that global settigns are handled before any 
services have been parsed from the config file.
Try setting 'printing = bsd' in [global].  If that works,
I'm going to close this as 'wont fix' since there is a workaround.
Comment 3 Andrei Nazarenko 2005-12-20 07:11:38 UTC
Many thanks for a speedy response!
I tried setting printing to bsd and then the error messages changed to the following:

[2005/12/20 15:07:53, 0] printing/pcap.c:pcap_cache_reload(159)
  Unable to open printcap file /etc/printcap for read!
[2005/12/20 15:07:53, 0] printing/pcap.c:pcap_cache_reload(159)
  Unable to open printcap file /etc/printcap for read!

(Why is it always trying twice? :-) )
After that I did 'touch /etc/printcap' and restarted smbd again.

No more errors this time - thanks for the workaround!
Comment 4 Gerald (Jerry) Carter 2005-12-20 07:17:21 UTC
Probably twice due to the initial load and then from the printcap
caching.