Bug 3295 - files on samba shares are all shown as directories within sfu
files on samba shares are all shown as directories within sfu
Status: RESOLVED DUPLICATE of bug 3287
Product: Samba 3.0
Classification: Unclassified
Component: File Services
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2005-11-30 17:29 UTC by Martin Koeppe
Modified: 2005-12-18 14:18 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Martin Koeppe 2005-11-30 17:29:14 UTC
If you mount a samba share on a W2K client with sfu, all files are shown as directories by ls, i.e.:

C:\> net use T: \\samba\tmp
C:\> T:
T:\> echo hello world > file
T:\> type file
hello world

Now go to sfu shell:

sfu:/dev/fs/T$ ls -l file
drw-rw-r--  1 3003  3003  14   Dec 1 01:15 file

File size is ok, you can even do
sfu:/dev/fs/T$ cat file
hello world

But you get an error for
sfu:/dev/fs/T$ echo 2 >> file
bash: file: Permission denied

On shares from a windows server, this doesn't occur.
Outside from sfu, everything is fine, too.
Comment 1 Jeremy Allison 2005-11-30 17:36:35 UTC
Please test this with the latest Samba 3.0.21 pre-release code (or the full release which will be released this week) as there have been many changes in this area.
Comment 2 Martin Koeppe 2005-12-01 03:57:35 UTC
I now tested with 3.0.21rc1, but the behaviour remains the same.

Just for completeness: the ls.exe from the sfu common dir reports the file as file, only within sfu, i.e. when using the binary C:\sfu\bin\ls, it is reported as directory.

C:\>c:\sfu\common\ls.exe -l T:\file
-rw-rw-r--  1 3003  3003  14 Dec  1 01:26 /dev/fs/T/file

(There is no change for #3287 either. I will add that there, too)
Comment 3 Martin Koeppe 2005-12-18 14:18:39 UTC

*** This bug has been marked as a duplicate of 3287 ***