Bug 3288 - %-Macros expanded in explicitly set passdb entries
%-Macros expanded in explicitly set passdb entries
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.20b
Other All
: P3 enhancement
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-28 13:47 UTC by Volker Lendecke
Modified: 2006-01-17 22:06 UTC (History)
0 users

See Also:


Attachments
Add passdb:expand_explicit (2.70 KB, patch)
2005-11-28 13:51 UTC, Volker Lendecke
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volker Lendecke 2005-11-28 13:47:44 UTC
When an admin enters some client-expanded variable like for example %G_osver% into the fields homedir, logon path or profile path, these variables are modified on the fly by the Samba DC code. So %G ends up at the client expanded as primary-group_osver% which is different from what the admin typed in. This is due to the fact that explictly set fields are sent through standard_sub_basic, so the macro expansions take place.

Volker
Comment 1 Volker Lendecke 2005-11-28 13:51:55 UTC
Created attachment 1599 [details]
Add passdb:expand_explicit

This adds the parameter passdb:expand_explicit that defaults to no, fixing the unexpected behaviour. If installations depend on expanding %-Macros in explicitly set fields, passdb:expand_explicit can be set to yes.

Volker
Comment 2 Gerald (Jerry) Carter 2006-01-17 22:06:01 UTC
This patch has been checked in.  Althought we need to 
have a non-ambiguous syntax.