Bug 3285 - segfault in smbd, nmbd, and testparm
segfault in smbd, nmbd, and testparm
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: nmbd
3.0.20b
x86 Linux
: P3 major
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-27 13:10 UTC by Eric Buddington
Modified: 2006-01-17 22:57 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Buddington 2005-11-27 13:10:30 UTC
./configure --prefix=/packages/samba/3.0.20b/any --exec-prefix=/packages/samba/3.0.20b/i386 i386

I get a segmentation fault immediate when running smbd, nmbd, or testparm:

-bash-2.05b# testparm /etc/smb.conf
Load smb config files from /etc/smb.conf
Processing section "[elena]"
Segmentation fault

-bash-2.05b# gdb /usr/bin/testparm  core
...
(gdb) where
#0  0xb7e00c82 in *__GI___strcasecmp (s1=0x809b43f "ASCII", s2=0x0)
    at ctype.h:47
#1  0x0807c36f in find_charset_functions ()
#2  0x0807c82d in smb_iconv_open ()
#3  0x08056df3 in init_iconv ()
#4  0x0805548e in lp_load ()
#5  0x0804c45e in main ()
Comment 1 Gerald (Jerry) Carter 2005-11-28 08:58:19 UTC
Looks like you have a bad iconv library.  What platform 
is this (hardware and OS)? 
Comment 2 Eric Buddington 2005-11-28 09:42:31 UTC
Processor: AMD Athlon(TM) XP 2000+
OS: Linux 2.6.15-rc1-mm2 #1 PREEMPT

My iconv library was 1.9.1. I upgraded to 1.10, but it didn't help.
./configure looks for giconv.h and doesn't find it - is this a problem? ./configure doesn't give an error; I just see it in config.log.

On the other hand, my testparm, smbd, and nmbd binaries are not dynamically linked against libiconv (and my libiconv does not include a static version). Since 'make' doesn't show the compile/link commands, I can't tell if it's using a built-in iconv, or my system's...
Comment 3 Gerald (Jerry) Carter 2006-01-17 22:05:08 UTC
I need your config.log.  Thanks.
Comment 4 Eric Buddington 2006-01-17 22:36:16 UTC
I've upgraded various things since then (including samba to 3.0.21a), and I can no longer reproduce the problem. I don't think I can add anything else useful - perhaps this should be closed?
Comment 5 Gerald (Jerry) Carter 2006-01-17 22:57:47 UTC
ok.  Thanks.  Closing out.