Bug 3251 - samba freezes cde
samba freezes cde
Status: RESOLVED WORKSFORME
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.20b
All All
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-09 10:59 UTC by mchugh19@yahoo.com
Modified: 2007-04-14 17:31 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mchugh19@yahoo.com 2005-11-09 10:59:19 UTC
On a Solaris 10 x86 machine running samba 3.0.20b I have run into a problem
where samba, most likely winbind, are freezing cde.

I am loggin into the machine with dtlogin using a local account. An account with
the same name happens to also exist in AD, but I have commented out all winbind
entries in pam and am using the local accounts password. After getting into cde,
if I close all open windows and programs, then attempt to start a terminal by
right clicking the desktop > Tools > Terminal: cde is frozen. I still have the
default system monitor cpu/disk active on the cde toolbar but that is all that
seems to function. The rest of cde is frozen. If I do the same steps with the
pam entries for winbind active and use a winbind account I get the same result.

Looking at the winbind log I when this happens I have a few hundred lines of:

[2005/11/09 10:28:30, 3] nsswitch/winbindd_ads.c:dn_lookup(346)
  ads: dn_lookup
[2005/11/09 10:28:30, 3] nsswitch/winbindd_ads.c:dn_lookup(346)
  ads: dn_lookup
[2005/11/09 10:28:30, 3] nsswitch/winbindd_ads.c:dn_lookup(346)
  ads: dn_lookup
[2005/11/09 10:28:30, 3] nsswitch/winbindd_ads.c:dn_lookup(346)
  ads: dn_lookup
[2005/11/09 10:28:30, 3] nsswitch/winbindd_ads.c:dn_lookup(346)
  ads: dn_lookup
[2005/11/09 10:28:30, 3] nsswitch/winbindd_ads.c:dn_lookup(346)
  ads: dn_lookup

If I stop samba then stop and start dtlogin I can open terminals without a
problem, so it seems to me to be samaba releated. 

Please let me know what logs or other information I can give to help.
Comment 1 mchugh19@yahoo.com 2005-11-09 11:08:58 UTC
Small update. I get the same results with samba 3.0.21-pre.
Comment 2 Gerald (Jerry) Carter 2005-11-09 11:23:20 UTC
Try setting 'winbind enum users = no' and 'winbind enum groups = no'
Comment 3 mchugh19@yahoo.com 2005-11-09 11:39:53 UTC
I have tried users and groups enum = no with the same results. I should also
mention that if I just start smbd and nmbd cde does not freeze. So it does
appear to be a winbind issue only.
Comment 4 mchugh19@yahoo.com 2005-11-15 09:35:55 UTC
I have attempted recreating this issue on a few other solaris 10 x86 machines without being able to duplicate it. So I guess that makes it a non issue for now. Thanks for the help.
Comment 5 mchugh19@yahoo.com 2005-11-15 09:42:30 UTC
Sorry, scratch that last bit. It has started appearing on other machines with different logins. So it is still reoccuring.
Comment 6 Gerald (Jerry) Carter 2005-11-22 09:00:31 UTC
I'm going to need raw snoop traces and level 10 debug logs.
You can send them to me dircetly if you prefer not to attach 
them to the bug report.
Comment 7 Gerald (Jerry) Carter 2007-04-14 17:31:23 UTC
no additional information.