Bug 3232 - smbcacls fails :NT_TRANSACT_SET_SECURITY_DESC
smbcacls fails :NT_TRANSACT_SET_SECURITY_DESC
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Client Tools
3.0.20b
x86 Linux
: P3 critical
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-01 15:48 UTC by Thomas Husfeldt
Modified: 2005-11-07 16:29 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Husfeldt 2005-11-01 15:48:00 UTC
I have two servers one running Fedora Core 2 (samba 3.0.3), and the other
running SUSE 9.3 and samba 3.0.20b.
On the first server everything works fine..
On the Suse server - runing the same smbcacls command I get the following error:
NT_TRANSACT_SET_SECURITY_DESC failed
ERROR: secdesc set failed: NT_STATUS_ACCESS_DENIED

I have tried to copy the smb.conf file from the fedora server, this did not
help, also I have tried with samba 3.0.12 (default installed by suse 9.3) and
this also did not work.
The command is shown below..
smbcacls  //MYDOMAIN/MYSHARE NAME_OF_FOLDER -U "DOMAIN/USER%PASSWORD" -a 
ACL:"VALID SID":ALLOWED/3/CHANGE 

The output in debug mode 5 is as follows:
Connecting to host=NKM18613
Connecting to 10.125.96.214 at port 445
Doing spnego session setup (blob length=113)
got OID=1 2 840 48018 1 2 2
got OID=1 2 840 113554 1 2 2
got OID=1 2 840 113554 1 2 2 3
got OID=1 3 6 1 4 1 311 2 2 10
got principal=nkm18922$@NYKREDITNET.NET
Got challenge flags:
Got NTLMSSP neg_flags=0x62890215
NTLMSSP: Set final flags:
Got NTLMSSP neg_flags=0x60080215
NTLMSSP Sign/Seal - Initialising with flags:
Got NTLMSSP neg_flags=0x60080215
NT_TRANSACT_SET_SECURITY_DESC failed
ERROR: secdesc set failed: NT_STATUS_ACCESS_DENIED
Comment 1 Thomas Husfeldt 2005-11-02 05:43:28 UTC
I tried something new...
I moved the pre-compiled version of smbcacls from the Fedora server onto the
Suse server along with the following libs..
/usr/lib/libldap.so.2
/usr/lib/liblber.so.2
/lib/libssl.so.4
/lib/libcrypto.so.4
When using the copied version of smbcacls (and corresponding libs as listed
above) I am amble to use smbcacls without problems.
Therefore I am pretty sure that the error is either:
- somewhere in the never versions of smbcacls or its libraries.
- In the compilation/packing of the Suse RPM's. (Notice however that I doubt
this is the issue, because i tried both the rpms from the distribution DVD, and
the 3.0.20b from the samba.org site,)
Comment 2 Jeremy Allison 2005-11-03 18:37:43 UTC
There were a couple of bugs in the smbcacls code I have fixed recently. Please
try the SAMBA_3_0 SVN code - it should be fixed there (or wait unitl the next
3.0.21 pre release).
Thanks,
Jeremy.
Comment 3 Jeremy Allison 2005-11-07 16:29:55 UTC
Fixed in 3.0.21.
Jeremy.