Bug 3213 - rmdir of empty directory via cygwin fails
rmdir of empty directory via cygwin fails
Status: RESOLVED DUPLICATE of bug 3216
Product: Samba 3.0
Classification: Unclassified
Component: File Services
x86 Windows 2000
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2005-10-25 19:30 UTC by Ahmon Dancy
Modified: 2005-10-26 05:47 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Ahmon Dancy 2005-10-25 19:30:40 UTC
Test scenario:

Map network drive F: to \\testhost\homedir

On the client side, start a cygwin shell and do: 
mkdir xxx
rmdir xxx

The rmdir command will fail with a "directory not empty" error.  Subsequent
attempts to not work either.   I suppose this may be a bug in cygwin but this
behavior does not occur when using samba-3.0.14a.

Client is Windows 2000 or Windows XP.
Comment 1 Jeremy Allison 2005-10-25 22:59:23 UTC
Can you send in an ethreeal capture trace please ?
Comment 2 Gerald (Jerry) Carter 2005-10-26 05:47:15 UTC
Reported in conjunction with folder deletion problems.
Closing this one as a sup.

*** This bug has been marked as a duplicate of 3216 ***