Bug 320 - Samba does not react well if non ASCII characters are in the group names
Samba does not react well if non ASCII characters are in the group names
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
Other other
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Depends on:
  Show dependency treegraph
Reported: 2003-08-19 06:00 UTC by Christoph Mertins
Modified: 2005-08-24 10:18 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Mertins 2003-08-19 06:00:30 UTC
wbinfo -g lists the groups as following


but "DomDomDomeLIP" should be the separate groups 1. "Domänen-Benutzer" and 2.

calling id on the command-line for the user returns the correct groups.
This is critical due to it blocks using these groups for share accounting.
Comment 1 Christoph Mertins 2003-08-19 06:19:05 UTC
after some more researching it seems like it finds the SIDs of the groups but
again it say no access
Comment 2 Gerald (Jerry) Carter 2003-08-25 09:26:37 UTC
Please retest with the latest SAMAB_3_0 cvs since we've 
made a few changes in the area since RC1.  Thanks.
Comment 3 Gerald (Jerry) Carter 2003-08-29 08:11:29 UTC
Will try again for RC3.
Comment 4 Gerald (Jerry) Carter 2003-08-29 08:11:53 UTC
Will try again for RC3.
Comment 5 Gerald (Jerry) Carter 2003-08-29 08:13:04 UTC
sorry.  didn't mean to close it.
Comment 6 Gerald (Jerry) Carter 2004-03-18 08:07:30 UTC
please retest 3.0.3pre1 (due out Mar 19).
Should be fixed.
Comment 7 Gerald (Jerry) Carter 2005-02-07 09:06:04 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 8 Gerald (Jerry) Carter 2005-08-24 10:18:47 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.