Bug 315 - Problem "mapping network drives" against smb server
Problem "mapping network drives" against smb server
Product: Samba 3.0
Classification: Unclassified
Component: File Services
All Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
Depends on:
  Show dependency treegraph
Reported: 2003-08-18 10:45 UTC by Henric Blomgren
Modified: 2005-11-14 09:29 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Henric Blomgren 2003-08-18 10:45:38 UTC
As of the 3.0 RC1 I have had virtually no sucess using the windows
NT 4 SP6a / 2000 Pro SP4 / XP Pro SP1 function to map network drives using 
A) An \\server\share style path
B) An \\ip\share style path
Both result in an "extended error" with no special samba log notifications nor 
any more possibile information in windows.

Already mapped network drives will NOT connect sucessfully on logon on NT4 
machines while they appear with a red x on windows machines and become 
accessable when you double click them after an 15 sec or so delay (100 Mbit 
switched lan, shouldent take that long really).

The server is running Debian 3, Kernel 2.4.20, packages compiled with GCC-3.3 
that came off APT-unstable.

Best regards,
Henric Blomgren
Comment 1 Brian King 2003-08-18 12:14:27 UTC
I have gotten the same error from windows at one point.
For me it was on Solaris and it turned out to be a 'cacheing' issue.

If I tried to connect to the same share using "smbclient -k \\\\SERVER\\SHARE"
the error returned was "NT_STATUS_NO_SUCH_USER".

The solution turned out to be to stop and start "nscd". It was apparantly 
caused by upgrading winbind, and nscd had not let go of the old library. If you 
don't have a similar nscd on Debian, or don't know what it is, maybe try a 

Hopefully this helps.
Comment 2 Henric Blomgren 2003-08-18 12:45:32 UTC
Hello Brian,

I've tried to reboot the server machine actually, even changed kernels down to 
2.4.18 once with the same effect, also rebooted windows clients several times. 
Nscd nor winbind is running on my system.

Tried connecting with smbclient -k \\\\server\\share, worked out fine so I 
guess it wasn't the issue?
Comment 3 Gerald (Jerry) Carter 2003-11-04 20:37:36 UTC
Cannot reproduce this.  Please reopen if you have more details to
help.  Have you tried updating to Samba 3.0.1 pre1?
Comment 4 Gerald (Jerry) Carter 2003-11-04 20:38:27 UTC
need a comment to close (cannpt reproduce).
Comment 5 Gerald (Jerry) Carter 2005-02-07 09:04:55 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 6 Gerald (Jerry) Carter 2005-11-14 09:29:54 UTC
database cleanup